# CVE-2023-49800: Denial of service by abusing `fetchOptions.retry` in nuxt-api-party

> Attackers can crash the server via stack overflow by abusing unfiltered retry options in the nuxt-api-party module.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-q6hx-3m4p-749h

## What is CVE-2023-49800?

CVE-2023-49800 is a high-severity denial of service vulnerability in johannschopplich nuxt-api-party, published on 8 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

`nuxt-api-party` is an open source module to proxy API requests. The library allows the user to send many options directly to `ofetch`. There is no filter on which options are available. We can abuse the retry logic to cause the server to crash from a stack overflow. fetchOptions are obtained directly from the request body. A malicious user can construct a URL known  to not fetch successfully, then set the retry attempts to a high value, this will cause a stack overflow as ofetch error handling works recursively resulting in a denial of service. This issue has been addressed in version 0.22.1. Users are advised to upgrade. Users unable to upgrade should limit ofetch options.

Weakness: CWE-787 (Out-of-bounds Write), CWE-674 (Uncontrolled Recursion), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-49800?

2 open source packages ship an affected version, including nuxt-api-party. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nuxt-api-party` | npm | All versions | 0.22.1 |
| `nuxt-api-party` | npm | All versions | 0.22.1 |

Products: Johannschopplich Nuxt Api Party.

## How do I fix CVE-2023-49800?

Upgrade nuxt-api-party to 0.22.1 or later.

## Is CVE-2023-49800 being exploited?

There is no known exploitation of CVE-2023-49800 in the wild and no public exploit code.

## Other vulnerabilities in johannschopplich nuxt-api-party

- [CVE-2023-49799](https://insights.sbomify.com/CVE-2023-49799/): Server-Side Request Forgery in nuxt-api-party (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49800 and fix it if it is affected.

What it is: CVE-2023-49800 is a high-severity denial of service vulnerability in johannschopplich nuxt-api-party, published on 8 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49800 in the wild and no public exploit code.

Affected packages and fixed versions:
- nuxt-api-party (npm): affected all versions; fixed in 0.22.1
- nuxt-api-party (npm): affected all versions; fixed in 0.22.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49800/ (Markdown: https://insights.sbomify.com/CVE-2023-49800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49800
- OSV: https://osv.dev/vulnerability/CVE-2023-49800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49800/
Summaries are generated and may contain mistakes; the official description above is the record.
