# CVE-2023-49802: MantisBT LinkedCustomFields Cross-site Scripting vulnerability

> An attacker can execute arbitrary JavaScript in MantisBT via crafted custom fields, potentially compromising user sessions.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Dec 2023
- **Updated:** 28 Aug 2024
- **Also known as:** GHSA-2f37-9xpx-5hhw

## What is CVE-2023-49802?

CVE-2023-49802 is a medium-severity cross-site scripting vulnerability in mantisbt-plugins LinkedCustomFields, published on 11 Dec 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The LinkedCustomFields plugin for MantisBT allows users to link values between two custom fields, creating linked drop-downs. Prior to version 2.0.1, cross-site scripting in the MantisBT LinkedCustomFields plugin allows Javascript execution, when a crafted Custom Field is linked via the plugin and displayed when reporting a new Issue or editing an existing one. This issue is fixed in version 2.0.1. As a workaround, one may utilize MantisBT's default Content Security Policy, which blocks script execution.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-49802?

It affects 1 product.


Products: Mantisbt Linked Custom Fields.

## How do I fix CVE-2023-49802?

No fix has been published for CVE-2023-49802 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-49802 being exploited?

There is no known exploitation of CVE-2023-49802 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49802 and fix it if it is affected.

What it is: CVE-2023-49802 is a medium-severity cross-site scripting vulnerability in mantisbt-plugins LinkedCustomFields, published on 11 Dec 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49802 in the wild and no public exploit code.

Affected product: mantisbt-plugins LinkedCustomFields. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49802/ (Markdown: https://insights.sbomify.com/CVE-2023-49802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49802
- OSV: https://osv.dev/vulnerability/CVE-2023-49802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49802/
Summaries are generated and may contain mistakes; the official description above is the record.
