# CVE-2023-49803: @koa/cors has overly permissive origin policy

> The @koa/cors library disables Same Origin Policy by reflecting request origins when no allowed origin is configured, exposing users to cross-origin attacks.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** CLSA-2026-1789052857, GHSA-qxrj-hx23-xp82

## What is CVE-2023-49803?

CVE-2023-49803 is a high-severity vulnerability in koajs cors, published on 11 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@koa/cors npm provides Cross-Origin Resource Sharing (CORS) for koa, a web framework for Node.js. Prior to version 5.0.0, the middleware operates in a way that if an allowed origin is not provided, it will return an `Access-Control-Allow-Origin` header with the value of the origin from the request. This behavior completely disables one of the most crucial elements of browsers - the Same Origin Policy (SOP), this could cause a very serious security threat to the users of this middleware. If such behavior is expected, for instance, when middleware is used exclusively for prototypes and not for production applications, it should be heavily emphasized in the documentation along with an indication of the risks associated with such behavior, as many users may not be aware of it. Version 5.0.0 fixes this vulnerability.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2023-49803?

2 open source packages ship an affected version, including @koa/cors. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@koa/cors` | npm | All versions | 5.0.0 |
| `@koa/cors` | npm | All versions | 5.0.0 |

Products: Koajs Cross-Origin Resource Sharing for Koa.

## How do I fix CVE-2023-49803?

Upgrade @koa/cors to 5.0.0 or later.

## Is CVE-2023-49803 being exploited?

There is no known exploitation of CVE-2023-49803 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49803 and fix it if it is affected.

What it is: CVE-2023-49803 is a high-severity vulnerability in koajs cors, published on 11 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49803 in the wild and no public exploit code.

Affected packages and fixed versions:
- @koa/cors (npm): affected all versions; fixed in 5.0.0
- @koa/cors (npm): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49803/ (Markdown: https://insights.sbomify.com/CVE-2023-49803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49803
- OSV: https://osv.dev/vulnerability/CVE-2023-49803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49803/
Summaries are generated and may contain mistakes; the official description above is the record.
