{"answers":{"affected":"2 open source packages ship an affected version, including uptime-kuma. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-49804 exists.","fix":"Upgrade uptime-kuma to 1.23.9 or later.","what":"CVE-2023-49804 is a medium-severity authentication bypass vulnerability in louislam uptime-kuma, published on 11 Dec 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-49804 and fix it if it is affected.\n\nWhat it is: CVE-2023-49804 is a medium-severity authentication bypass vulnerability in louislam uptime-kuma, published on 11 Dec 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-49804 exists.\n\nAffected packages and fixed versions:\n- uptime-kuma (npm): affected all versions; fixed in 1.23.9\n- uptime-kuma (npm): affected all versions; fixed in 1.23.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-49804/ (Markdown: https://insights.sbomify.com/CVE-2023-49804/index.md)","id":"CVE-2023-49804","markdown":"https://insights.sbomify.com/CVE-2023-49804/index.md","name":"CVE-2023-49804","record":{"aliases":["GHSA-88j4-pcx8-q4q3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Uptime Kuma monitoring tool","requires_auth":"high_privilege","summary":"Attackers can retain unauthorized access to user accounts after password changes because existing sessions are not invalidated, compromising account security.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dockge","vendor":"dockge.kuma"},{"product":"uptime_kuma","vendor":"uptime.kuma"}],"cvss":{"score":6.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-384","name":"Session Fixation"}],"description":"Uptime Kuma is an easy-to-use self-hosted monitoring tool. Prior to version 1.23.9, when a user changes their login password in Uptime Kuma, a previously logged-in user retains access without being logged out. This behavior persists consistently, even after system restarts or browser restarts. This vulnerability allows unauthorized access to user accounts, compromising the security of sensitive information. The same vulnerability was partially fixed in  CVE-2023-44400, but logging existing users out of their accounts was forgotten. To mitigate the risks associated with this vulnerability, the maintainers made the server emit a `refresh` event (clients handle this by reloading) and then disconnecting all clients except the one initiating the password change. It is recommended to update Uptime Kuma to version 1.23.9.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Uptime Kuma Password Change Vulnerability","id":"CVE-2023-49804","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Uptime Kuma Missing Origin Validation in WebSockets","id":"CVE-2023-49805"},"packages":[{"ecosystem":"npm","fixed":["1.23.9"],"introduced":["0"],"last_affected":[],"package":"uptime-kuma","purl":null,"source":"GHSA-88j4-pcx8-q4q3"},{"ecosystem":"npm","fixed":["1.23.9"],"introduced":["0"],"last_affected":[],"package":"uptime-kuma","purl":"pkg:npm/uptime-kuma","source":"GHSA-88j4-pcx8-q4q3"}],"prev":{"headline":"@koa/cors has overly permissive origin policy","id":"CVE-2023-49803"},"products":["uptime-kuma"],"published":"2023-12-11","related":[{"cvss_score":6,"headline":"Uptime Kuma Missing Origin Validation in WebSockets","id":"CVE-2023-49805","kev_date_added":null,"published":"2023-12-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-09","vendors":["louislam"]},"summary":"Attackers can retain unauthorized access to user accounts after password changes because existing sessions are not invalidated, compromising account security.","url":"https://insights.sbomify.com/CVE-2023-49804/"}