# CVE-2023-49804: Uptime Kuma Password Change Vulnerability

> Attackers can retain unauthorized access to user accounts after password changes because existing sessions are not invalidated, compromising account security.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2023
- **Updated:** 9 Oct 2024
- **Also known as:** GHSA-88j4-pcx8-q4q3

## What is CVE-2023-49804?

CVE-2023-49804 is a medium-severity authentication bypass vulnerability in louislam uptime-kuma, published on 11 Dec 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Uptime Kuma is an easy-to-use self-hosted monitoring tool. Prior to version 1.23.9, when a user changes their login password in Uptime Kuma, a previously logged-in user retains access without being logged out. This behavior persists consistently, even after system restarts or browser restarts. This vulnerability allows unauthorized access to user accounts, compromising the security of sensitive information. The same vulnerability was partially fixed in  CVE-2023-44400, but logging existing users out of their accounts was forgotten. To mitigate the risks associated with this vulnerability, the maintainers made the server emit a `refresh` event (clients handle this by reloading) and then disconnecting all clients except the one initiating the password change. It is recommended to update Uptime Kuma to version 1.23.9.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2023-49804?

2 open source packages ship an affected version, including uptime-kuma. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uptime-kuma` | npm | All versions | 1.23.9 |
| `uptime-kuma` | npm | All versions | 1.23.9 |

Products: Dockge.kuma Dockge, Uptime.kuma Uptime Kuma.

## How do I fix CVE-2023-49804?

Upgrade uptime-kuma to 1.23.9 or later.

## Is CVE-2023-49804 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-49804 exists.

## Other vulnerabilities in louislam uptime-kuma

- [CVE-2023-49805](https://insights.sbomify.com/CVE-2023-49805/): Uptime Kuma Missing Origin Validation in WebSockets (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49804 and fix it if it is affected.

What it is: CVE-2023-49804 is a medium-severity authentication bypass vulnerability in louislam uptime-kuma, published on 11 Dec 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-49804 exists.

Affected packages and fixed versions:
- uptime-kuma (npm): affected all versions; fixed in 1.23.9
- uptime-kuma (npm): affected all versions; fixed in 1.23.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49804/ (Markdown: https://insights.sbomify.com/CVE-2023-49804/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49804
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49804
- OSV: https://osv.dev/vulnerability/CVE-2023-49804

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49804/
Summaries are generated and may contain mistakes; the official description above is the record.
