CVE-2023-49920 Apache Airflow: Missing CSRF protection on DAG/trigger

Medium 6.5 Published Updated

Attackers can trigger DAG execution via GET requests without CSRF validation, potentially leading to unauthorized code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-49920?

CVE-2023-49920 is a medium-severity vulnerability in Apache Airflow, published on 21 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected

Weakness: CWE-352

Which versions are affected by CVE-2023-49920?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIFrom 2.7.02.8.0
apache-airflow PyPIFrom 2.7.02.8.0
apache-airflow PyPIFrom 2.7.02.8.0b1
airflow BitnamiFrom 2.7.02.7.4

Products include Apache Airflow.

How do I fix CVE-2023-49920?

Upgrade apache-airflow to a fixed version for your release line: 2.8.0 or 2.8.0b1.

Is CVE-2023-49920 being exploited?

There is no known exploitation of CVE-2023-49920 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2023-49920, ECHO-e9ac-f08e-3a77, GHSA-6m9r-7wrx-xmr6, PYSEC-2023-266.

Is CVE-2023-49920 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free