# CVE-2023-49920: Apache Airflow: Missing CSRF protection on DAG/trigger

> Attackers can trigger DAG execution via GET requests without CSRF validation, potentially leading to unauthorized code execution.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Dec 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-airflow-2023-49920, ECHO-e9ac-f08e-3a77, GHSA-6m9r-7wrx-xmr6, PYSEC-2023-266

## What is CVE-2023-49920?

CVE-2023-49920 is a medium-severity vulnerability in Apache Airflow, published on 21 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent.
Users are advised to upgrade to version 2.8.0 or later which is not affected

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-49920?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 2.7.0 | 2.8.0 |
| `apache-airflow` | PyPI | From 2.7.0 | 2.8.0 |
| `apache-airflow` | PyPI | From 2.7.0 | 2.8.0b1 |
| `airflow` | Bitnami | From 2.7.0 | 2.7.4 |

Products: Apache Airflow.

## How do I fix CVE-2023-49920?

Upgrade apache-airflow to a fixed version for your release line: 2.8.0 or 2.8.0b1.

## Is CVE-2023-49920 being exploited?

There is no known exploitation of CVE-2023-49920 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-49920 and fix it if it is affected.

What it is: CVE-2023-49920 is a medium-severity vulnerability in Apache Airflow, published on 21 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-49920 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 2.7.0; fixed in 2.8.0
- apache-airflow (PyPI): affected from 2.7.0; fixed in 2.8.0
- apache-airflow (PyPI): affected from 2.7.0; fixed in 2.8.0b1
- airflow (Bitnami): affected from 2.7.0; fixed in 2.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-49920/ (Markdown: https://insights.sbomify.com/CVE-2023-49920/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-49920
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-49920
- OSV: https://osv.dev/vulnerability/CVE-2023-49920

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-49920/
Summaries are generated and may contain mistakes; the official description above is the record.
