{"answers":{"affected":"3 open source packages ship an affected version, including pgadmin4. It affects 2 products.","exploited":"There is no known exploitation of CVE-2023-5002 in the wild and no public exploit code.","fix":"Upgrade pgadmin4 to 7.7 or later.","what":"CVE-2023-5002 is a medium-severity command injection vulnerability in Fedoraproject Fedora, published on 22 Sep 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-5002 and fix it if it is affected.\n\nWhat it is: CVE-2023-5002 is a medium-severity command injection vulnerability in Fedoraproject Fedora, published on 22 Sep 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-5002 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgadmin4 (PyPI): affected all versions; fixed in 7.7\n- pgadmin4 (PyPI): affected all versions; fixed in 7.7\n- pgadmin4 (PyPI): affected all versions; fixed in 7.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-5002/ (Markdown: https://insights.sbomify.com/CVE-2023-5002/index.md)","id":"CVE-2023-5002","markdown":"https://insights.sbomify.com/CVE-2023-5002/index.md","name":"CVE-2023-5002","record":{"aliases":["GHSA-ghp8-52vx-77j4","PYSEC-2026-1774","openSUSE-SU-2024:13379-1"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL management tool","requires_auth":"high_privilege","summary":"An authenticated user can execute arbitrary commands on the server via improper validation of PostgreSQL utility paths in pgAdmin.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"pgadmin_4","vendor":"pgadmin"}],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"A flaw was found in pgAdmin. This issue occurs when the pgAdmin server HTTP API validates the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. Versions of pgAdmin prior to 7.6 failed to properly control the server code executed on this API, allowing an authenticated user to run arbitrary commands on the server.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pgadmin4: remote code execution by an authenticated user","id":"CVE-2023-5002","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"command_injection","year":"2023"},"n_packages":4,"n_references":4,"next":{"headline":"Active Directory Integration \u003c 4.1.10 - Unauthenticated Log Disclosure","id":"CVE-2023-5003"},"packages":[{"ecosystem":"PyPI","fixed":["7.7"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":null,"source":"GHSA-ghp8-52vx-77j4"},{"ecosystem":"PyPI","fixed":["7.7"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"GHSA-ghp8-52vx-77j4"},{"ecosystem":"PyPI","fixed":["7.7"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"PYSEC-2026-1774"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["7.8-1.1"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:rpm/opensuse/pgadmin4\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13379-1"}],"prev":{"headline":"Horizontal scrolling announcement \u003c= 9.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode","id":"CVE-2023-5001"},"products":["fedoraproject:fedora","pgadmin:pgadmin_4"],"published":"2023-09-22","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["fedoraproject","pgadmin"]},"summary":"An authenticated user can execute arbitrary commands on the server via improper validation of PostgreSQL utility paths in pgAdmin.","url":"https://insights.sbomify.com/CVE-2023-5002/"}