# CVE-2023-5002: Pgadmin4: remote code execution by an authenticated user

> An authenticated user can execute arbitrary commands on the server via improper validation of PostgreSQL utility paths in pgAdmin.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Sep 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-ghp8-52vx-77j4, PYSEC-2026-1774, openSUSE-SU-2024:13379-1

## What is CVE-2023-5002?

CVE-2023-5002 is a medium-severity command injection vulnerability in Fedoraproject Fedora, published on 22 Sep 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A flaw was found in pgAdmin. This issue occurs when the pgAdmin server HTTP API validates the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. Versions of pgAdmin prior to 7.6 failed to properly control the server code executed on this API, allowing an authenticated user to run arbitrary commands on the server.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2023-5002?

3 open source packages ship an affected version, including pgadmin4. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 7.7 |
| `pgadmin4` | PyPI | All versions | 7.7 |
| `pgadmin4` | PyPI | All versions | 7.7 |
| `pgadmin4` | openSUSE:Tumbleweed | All versions | 7.8-1.1 |

Products: Fedoraproject Fedora, Pgadmin Pgadmin 4.

## How do I fix CVE-2023-5002?

Upgrade pgadmin4 to 7.7 or later.

## Is CVE-2023-5002 being exploited?

There is no known exploitation of CVE-2023-5002 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5002 and fix it if it is affected.

What it is: CVE-2023-5002 is a medium-severity command injection vulnerability in Fedoraproject Fedora, published on 22 Sep 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-5002 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 7.7
- pgadmin4 (PyPI): affected all versions; fixed in 7.7
- pgadmin4 (PyPI): affected all versions; fixed in 7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5002/ (Markdown: https://insights.sbomify.com/CVE-2023-5002/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5002
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5002
- OSV: https://osv.dev/vulnerability/CVE-2023-5002

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5002/
Summaries are generated and may contain mistakes; the official description above is the record.
