CVE-2023-5009 Incorrect Authorization in GitLab

High 8.2 Published Updated

Attackers can execute pipeline jobs as arbitrary users via scheduled security scan policies, leading to privilege escalation and potential code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-5009?

CVE-2023-5009 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 19 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 13.12 before 16.2.7, all versions starting from 16.3 before 16.3.4. It was possible for an attacker to run pipeline jobs as an arbitrary user via scheduled security scan policies. This was a bypass of [CVE-2023-3932](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-3932) showing additional impact.

Weakness: CWE-863

Which versions are affected by CVE-2023-5009?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.12.016.2.7, 16.3.4

Products include Gitlab Gitlab.

How do I fix CVE-2023-5009?

Upgrade gitlab to a fixed version for your release line: 16.2.7 or 16.3.4.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-5009 being exploited?

There is no known exploitation of CVE-2023-5009 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-5009, GHSA-g4c2-hhjc-4hgg.

Is CVE-2023-5009 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free