# CVE-2023-5009: Incorrect Authorization in GitLab

> Attackers can execute pipeline jobs as arbitrary users via scheduled security scan policies, leading to privilege escalation and potential code execution.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2023
- **Updated:** 28 Oct 2026
- **Also known as:** BIT-gitlab-2023-5009, GHSA-g4c2-hhjc-4hgg

## What is CVE-2023-5009?

CVE-2023-5009 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 19 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue has been discovered in GitLab EE affecting all versions starting from 13.12 before 16.2.7, all versions starting from 16.3 before 16.3.4. It was possible for an attacker to run pipeline jobs as an arbitrary user via scheduled security scan policies. This was a bypass of [CVE-2023-3932](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-3932) showing additional impact.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-5009?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 13.12.0 | 16.2.7, 16.3.4 |

Products: Gitlab Gitlab.

## How do I fix CVE-2023-5009?

Upgrade gitlab to a fixed version for your release line: 16.2.7 or 16.3.4.

## Is CVE-2023-5009 being exploited?

There is no known exploitation of CVE-2023-5009 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5009 and fix it if it is affected.

What it is: CVE-2023-5009 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 19 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-5009 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 13.12.0; fixed in 16.2.7, 16.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5009/ (Markdown: https://insights.sbomify.com/CVE-2023-5009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5009
- OSV: https://osv.dev/vulnerability/CVE-2023-5009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5009/
Summaries are generated and may contain mistakes; the official description above is the record.
