# CVE-2023-50164: Apache Struts: File upload component had a directory traversal vulnerability

> Attackers can exploit directory traversal in file uploads to upload malicious files and execute remote code, requiring an upgrade to patched Struts versions.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2023
- **Updated:** 14 Mar 2025
- **Also known as:** GHSA-2j39-qcjm-428w

## What is CVE-2023-50164?

CVE-2023-50164 is a critical path traversal vulnerability in Apache Struts, published on 7 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution.
Users are recommended to upgrade to versions Struts 2.5.33 or Struts 6.3.0.2 or greater to fix this issue.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2023-50164?

4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.5.33 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.5.33 |
| `org.apache.struts:struts2-core` | Maven | From 6.0.0 | 6.3.0.2 |
| `org.apache.struts:struts2-core` | Maven | From 6.0.0 | 6.3.0.2 |

Products: Apache Struts.

## How do I fix CVE-2023-50164?

Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.5.33 or 6.3.0.2.

## Is CVE-2023-50164 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50164 exists.

Public exploit code:

- A critical security vulnerability, identified as CVE-2023-50164 (CVE: 9.8) was found in Apache Struts, allowing attackers to manipulate file upload parameters that can potentially lead to unauthorized path traversal and remote code execution (RCE). (github_poc): https://github.com/jakabakos/CVE-2023-50164-Apache-Struts-RCE
- Proof of Concept for Path Traversal in Apache Struts ("CVE-2023-50164") (github_poc): https://github.com/dwisiswant0/cve-2023-50164-poc
- Vulnerable docker container for Apache Struts 2 RCE CVE-2023-50164 (github_poc): https://github.com/Trackflaw/CVE-2023-50164-ApacheStruts2-Docker
- https://github.com/snyk-labs/CVE-2023-50164-POC (github_poc): https://github.com/snyk-labs/CVE-2023-50164-POC
- A scanning utility and PoC for CVE-2023-50164 (github_poc): https://github.com/bcdannyboy/CVE-2023-50164
- Vulnerable docker container for Really Simple Security (Free, Pro, and Pro Multisite) 9.0.0 – 9.1.1.1 – Authentication Bypass CVE-2023-50164 (github_poc): https://github.com/Trackflaw/CVE-2024-10924-Wordpress-Docker

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50164 and fix it if it is affected.

What it is: CVE-2023-50164 is a critical path traversal vulnerability in Apache Struts, published on 7 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50164 exists.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.5.33
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.5.33
- org.apache.struts:struts2-core (Maven): affected from 6.0.0; fixed in 6.3.0.2
- org.apache.struts:struts2-core (Maven): affected from 6.0.0; fixed in 6.3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50164/ (Markdown: https://insights.sbomify.com/CVE-2023-50164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50164
- OSV: https://osv.dev/vulnerability/CVE-2023-50164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50164/
Summaries are generated and may contain mistakes; the official description above is the record.
