# CVE-2023-50245: OpenEXR-viewer memory overflow vulnerability

> An attacker can exploit a memory overflow in the OpenEXR viewer to potentially execute arbitrary code or cause a denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-99jg-r3f4-rpxj

## What is CVE-2023-50245?

CVE-2023-50245 is a critical memory corruption vulnerability in afichet openexr-viewer, published on 11 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenEXR-viewer is a viewer for OpenEXR files with detailed metadata probing. Versions prior to 0.6.1 have a memory overflow vulnerability. This issue is fixed in version 0.6.1.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2023-50245?

1 open source package ship an affected version, including afichet/openexr-viewer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `afichet/openexr-viewer` | GitHub Actions | All versions | 0.6.1 |

Products: Afichet Openexr Viewer.

## How do I fix CVE-2023-50245?

Upgrade afichet/openexr-viewer to 0.6.1 or later.

## Is CVE-2023-50245 being exploited?

There is no known exploitation of CVE-2023-50245 in the wild and no public exploit code.

Public exploit code:

- exr viewer (github_poc): https://github.com/200101WhoAmI/CVE-2023-50245

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50245 and fix it if it is affected.

What it is: CVE-2023-50245 is a critical memory corruption vulnerability in afichet openexr-viewer, published on 11 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-50245 in the wild and no public exploit code.

Affected packages and fixed versions:
- afichet/openexr-viewer (GitHub Actions): affected all versions; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50245/ (Markdown: https://insights.sbomify.com/CVE-2023-50245/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50245
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50245
- OSV: https://osv.dev/vulnerability/CVE-2023-50245

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50245/
Summaries are generated and may contain mistakes; the official description above is the record.
