# CVE-2023-50248: CKAN out of memory error when submitting the dataset form with a specially-crafted field

> An authenticated attacker with dataset creation permissions can cause a server out-of-memory denial of service by submitting a specially crafted field to the dataset form.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-7fgc-89cx-w8j5, PYSEC-2026-1249

## What is CVE-2023-50248?

CVE-2023-50248 is a medium-severity denial of service vulnerability in ckan, published on 13 Dec 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

CKAN is an open-source data management system for powering data hubs and data portals. Starting in version 2.0.0 and prior to versions 2.9.10 and 2.10.3, when submitting a POST request to the `/dataset/new` endpoint (including either the auth cookie or the `Authorization` header) with a specially-crafted field, an attacker can create an out-of-memory error in the hosting server. To trigger this error, the attacker need to have permissions to create or edit datasets. This vulnerability has been patched in CKAN 2.10.3 and 2.9.10.

Weakness: CWE-130 (Improper Handling of Length Parameter Inconsistency)

## Which versions are affected by CVE-2023-50248?

5 open source packages ship an affected version, including ckan. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckan` | PyPI | From 2.0 | 2.9.10, 2.10.3 |
| `ckan` | PyPI | From 2.0 | 2.9.10 |
| `ckan` | PyPI | From 2.0 | 2.9.10 |
| `ckan` | PyPI | From 2.10.0 | 2.10.3 |
| `ckan` | PyPI | From 2.10.0 | 2.10.3 |

Products: Okfn Ckan.

## How do I fix CVE-2023-50248?

Upgrade ckan to a fixed version for your release line: 2.9.10 or 2.10.3.

## Is CVE-2023-50248 being exploited?

There is no known exploitation of CVE-2023-50248 in the wild and no public exploit code.

## Other vulnerabilities in ckan

- [CVE-2023-32321](https://insights.sbomify.com/CVE-2023-32321/): CKAN remote code execution and private information access via crafted resource ids (critical 9.8)
- [CVE-2023-32696](https://insights.sbomify.com/CVE-2023-32696/): Excessive permissions for ckan user (high 8.8)
- [CVE-2022-43685](https://insights.sbomify.com/CVE-2022-43685/): CKAN contains Improper Authentication leading to account takeover (high 8.8)
- [CVE-2023-22746](https://insights.sbomify.com/CVE-2023-22746/): CKAN is vulnerable to session secret shared across instances using Docker images (high 8.6)
- [CVE-2026-42031](https://insights.sbomify.com/CVE-2026-42031/): CKAN: Unauthenticated SQL Injection and Authorization Bypass in `datastore_search_sql` (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50248 and fix it if it is affected.

What it is: CVE-2023-50248 is a medium-severity denial of service vulnerability in ckan, published on 13 Dec 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-50248 in the wild and no public exploit code.

Affected packages and fixed versions:
- ckan (PyPI): affected from 2.0; fixed in 2.9.10, 2.10.3
- ckan (PyPI): affected from 2.0; fixed in 2.9.10
- ckan (PyPI): affected from 2.0; fixed in 2.9.10
- ckan (PyPI): affected from 2.10.0; fixed in 2.10.3
- ckan (PyPI): affected from 2.10.0; fixed in 2.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50248/ (Markdown: https://insights.sbomify.com/CVE-2023-50248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50248
- OSV: https://osv.dev/vulnerability/CVE-2023-50248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50248/
Summaries are generated and may contain mistakes; the official description above is the record.
