{"answers":{"affected":"2 open source packages ship an affected version, including @sentry/astro. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-50249 in the wild and no public exploit code.","fix":"Upgrade @sentry/astro to 7.87.0 or later.","what":"CVE-2023-50249 is a high-severity denial of service vulnerability in getsentry sentry-javascript, published on 20 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-50249 and fix it if it is affected.\n\nWhat it is: CVE-2023-50249 is a high-severity denial of service vulnerability in getsentry sentry-javascript, published on 20 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-50249 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @sentry/astro (npm): affected from 7.78.0; fixed in 7.87.0\n- @sentry/astro (npm): affected from 7.78.0; fixed in 7.87.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-50249/ (Markdown: https://insights.sbomify.com/CVE-2023-50249/index.md)","id":"CVE-2023-50249","markdown":"https://insights.sbomify.com/CVE-2023-50249/index.md","name":"CVE-2023-50249","record":{"aliases":["GHSA-x3v3-8xg8-8v72"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Sentry Astro SDK","requires_auth":"none","summary":"An attacker can cause server denial of service via excessive computation in the Sentry Astro SDK, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"astro","vendor":"sentry"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Sentry-Javascript is official Sentry SDKs for JavaScript. A ReDoS (Regular expression Denial of Service) vulnerability has been identified in Sentry's Astro SDK 7.78.0-7.86.0. Under certain conditions, this vulnerability allows an attacker to cause excessive computation times on the server, leading to denial of service (DoS). This vulnerability has been patched in sentry/astro version 7.87.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sentry's Astro SDK vulnerable to ReDoS","id":"CVE-2023-50249","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-Site Scripting vulnerability when Import xml template file","id":"CVE-2023-50250"},"packages":[{"ecosystem":"npm","fixed":["7.87.0"],"introduced":["7.78.0"],"last_affected":[],"package":"@sentry/astro","purl":null,"source":"GHSA-x3v3-8xg8-8v72"},{"ecosystem":"npm","fixed":["7.87.0"],"introduced":["7.78.0"],"last_affected":[],"package":"@sentry/astro","purl":"pkg:npm/%40sentry/astro","source":"GHSA-x3v3-8xg8-8v72"}],"prev":{"headline":"CKAN out of memory error when submitting the dataset form with a specially-crafted field","id":"CVE-2023-50248"},"products":["sentry-javascript"],"published":"2023-12-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["getsentry"]},"summary":"An attacker can cause server denial of service via excessive computation in the Sentry Astro SDK, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2023-50249/"}