# CVE-2023-50249: Sentry's Astro SDK vulnerable to ReDoS

> An attacker can cause server denial of service via excessive computation in the Sentry Astro SDK, requiring an upgrade to the latest version.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-x3v3-8xg8-8v72

## What is CVE-2023-50249?

CVE-2023-50249 is a high-severity denial of service vulnerability in getsentry sentry-javascript, published on 20 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sentry-Javascript is official Sentry SDKs for JavaScript. A ReDoS (Regular expression Denial of Service) vulnerability has been identified in Sentry's Astro SDK 7.78.0-7.86.0. Under certain conditions, this vulnerability allows an attacker to cause excessive computation times on the server, leading to denial of service (DoS). This vulnerability has been patched in sentry/astro version 7.87.0.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-50249?

2 open source packages ship an affected version, including @sentry/astro. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sentry/astro` | npm | From 7.78.0 | 7.87.0 |
| `@sentry/astro` | npm | From 7.78.0 | 7.87.0 |

Products: Sentry Astro.

## How do I fix CVE-2023-50249?

Upgrade @sentry/astro to 7.87.0 or later.

## Is CVE-2023-50249 being exploited?

There is no known exploitation of CVE-2023-50249 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50249 and fix it if it is affected.

What it is: CVE-2023-50249 is a high-severity denial of service vulnerability in getsentry sentry-javascript, published on 20 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-50249 in the wild and no public exploit code.

Affected packages and fixed versions:
- @sentry/astro (npm): affected from 7.78.0; fixed in 7.87.0
- @sentry/astro (npm): affected from 7.78.0; fixed in 7.87.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50249/ (Markdown: https://insights.sbomify.com/CVE-2023-50249/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50249
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50249
- OSV: https://osv.dev/vulnerability/CVE-2023-50249

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50249/
Summaries are generated and may contain mistakes; the official description above is the record.
