{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-50254 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2023-50254 is a critical path traversal vulnerability in linuxdeepin developer-center, published on 22 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-50254 and fix it if it is affected.\n\nWhat it is: CVE-2023-50254 is a critical path traversal vulnerability in linuxdeepin developer-center, published on 22 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-50254 in the wild and no public exploit code.\n\nAffected product: linuxdeepin developer-center. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-50254/ (Markdown: https://insights.sbomify.com/CVE-2023-50254/index.md)","id":"CVE-2023-50254","markdown":"https://insights.sbomify.com/CVE-2023-50254/index.md","name":"CVE-2023-50254","record":{"aliases":["GHSA-q9jr-726g-9495","openSUSE-SU-2024:13536-1"],"analysis":{"component_type":"desktop_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Deepin Reader","requires_auth":"none","summary":"Attackers can achieve remote code execution by tricking users into opening a crafted docx file that overwrites shell configuration files.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"deepin_reader","vendor":"deepin"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-27","name":"Path Traversal: 'dir/../../filename'"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Deepin Linux's default document reader `deepin-reader` software suffers from a serious vulnerability in versions prior to 6.0.7 due to a design flaw that leads to remote command execution via crafted docx document. This is a file overwrite vulnerability. Remote code execution (RCE) can be achieved by overwriting files like .bash_rc, .bash_login, etc. RCE will be triggered when the user opens the terminal. Version 6.0.7 contains a patch for the issue.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2023-12-22","github_poc":1,"max_poc_stars":16,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-12-22T06:50:28Z","kind":"github_poc","ref":"https://github.com/febinrev/deepin-linux_reader_RCE-exploit","stars":16,"title":"CVE-2023-50254: PoC Exploit for Deepin-reader RCE that affects unpatched Deepin Linux Desktops. Deepin Linux's default document reader \"deepin-reader\" software suffers from a serious vulnerability due to a design flaw that leads to Remote Command Execution via crafted docx document."}],"tier":"poc_unverified"},"has_fix":true,"headline":"Deepin Reader RCE vulnerability due to a design flaw","id":"CVE-2023-50254","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":1,"n_references":3,"next":{"headline":"Zip Path Traversal in Deepin-Compressor","id":"CVE-2023-50255"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.10.23-2.1"],"introduced":["0"],"last_affected":[],"package":"deepin-reader","purl":"pkg:rpm/opensuse/deepin-reader\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13536-1"}],"prev":{"headline":"laf logs leak","id":"CVE-2023-50253"},"products":["developer-center"],"published":"2023-12-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["linuxdeepin"]},"summary":"Attackers can achieve remote code execution by tricking users into opening a crafted docx file that overwrites shell configuration files.","url":"https://insights.sbomify.com/CVE-2023-50254/"}