CVE-2023-50255 Zip Path Traversal in Deepin-Compressor
Attackers can achieve remote code execution on Deepin Linux systems by tricking users into opening crafted archives with the default compressor.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-50255?
CVE-2023-50255 is a critical path traversal vulnerability in linuxdeepin developer-center, published on 27 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability.
Which versions are affected by CVE-2023-50255?
It affects 1 product.
Linux distribution packages (5)
deepin-compressor SUSE:Package Hub 15 SP4 | All versions | 5.12.2-bp154.2.3.1 |
deepin-compressor SUSE:Package Hub 15 SP5 | All versions | 5.12.13-bp155.2.3.1 |
deepin-compressor openSUSE:Leap 15.4 | All versions | 5.12.2-bp154.2.3.1 |
deepin-compressor openSUSE:Leap 15.5 | All versions | 5.12.13-bp155.2.3.1 |
deepin-compressor openSUSE:Tumbleweed | All versions | 5.12.13-2.1 |
Products include Deepin Deepin-Compressor.
How do I fix CVE-2023-50255?
Upgrade to a fixed version.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2023-50255 being exploited?
There is no known exploitation of CVE-2023-50255 in the wild and no public exploit code.
Sources
Also known as GHSA-rw5r-8p9h-3gp2, OESA-2026-3506, OESA-2026-3507, OESA-2026-3508, OESA-2026-3509, openSUSE-SU-2023:0423-1 and 2 more.