{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-50255 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-50255 is a critical path traversal vulnerability in linuxdeepin developer-center, published on 27 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-50255 and fix it if it is affected.\n\nWhat it is: CVE-2023-50255 is a critical path traversal vulnerability in linuxdeepin developer-center, published on 27 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-50255 in the wild and no public exploit code.\n\nAffected product: linuxdeepin developer-center. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-50255/ (Markdown: https://insights.sbomify.com/CVE-2023-50255/index.md)","id":"CVE-2023-50255","markdown":"https://insights.sbomify.com/CVE-2023-50255/index.md","name":"CVE-2023-50255","record":{"aliases":["GHSA-rw5r-8p9h-3gp2","OESA-2026-3506","OESA-2026-3507","OESA-2026-3508","OESA-2026-3509","openSUSE-SU-2023:0423-1","openSUSE-SU-2023:0424-1","openSUSE-SU-2024:13541-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Deepin archive manager","requires_auth":"none","summary":"Attackers can achieve remote code execution on Deepin Linux systems by tricking users into opening crafted archives with the default compressor.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"deepin-compressor","vendor":"deepin"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-23","name":"Relative Path Traversal"},{"id":"CWE-26","name":"Path Traversal: '/dir/../filename'"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability.","ecosystems":["SUSE:Package Hub 15 SP4","SUSE:Package Hub 15 SP5","openSUSE:Leap 15.4","openSUSE:Leap 15.5","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Zip Path Traversal in Deepin-Compressor","id":"CVE-2023-50255","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":5,"n_references":2,"next":{"headline":"Froxlor username/surname AND company field Bypass","id":"CVE-2023-50256"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP4","fixed":["5.12.2-bp154.2.3.1"],"introduced":["0"],"last_affected":[],"package":"deepin-compressor","purl":"pkg:rpm/suse/deepin-compressor\u0026distro=SUSE%20Package%20Hub%2015%20SP4","source":"openSUSE-SU-2023:0424-1"},{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["5.12.13-bp155.2.3.1"],"introduced":["0"],"last_affected":[],"package":"deepin-compressor","purl":"pkg:rpm/suse/deepin-compressor\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2023:0423-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["5.12.2-bp154.2.3.1"],"introduced":["0"],"last_affected":[],"package":"deepin-compressor","purl":"pkg:rpm/opensuse/deepin-compressor\u0026distro=openSUSE%20Leap%2015.4","source":"openSUSE-SU-2023:0424-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["5.12.13-bp155.2.3.1"],"introduced":["0"],"last_affected":[],"package":"deepin-compressor","purl":"pkg:rpm/opensuse/deepin-compressor\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2023:0423-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.12.13-2.1"],"introduced":["0"],"last_affected":[],"package":"deepin-compressor","purl":"pkg:rpm/opensuse/deepin-compressor\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13541-1"}],"prev":{"headline":"Deepin Reader RCE vulnerability due to a design flaw","id":"CVE-2023-50254"},"products":["developer-center"],"published":"2023-12-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["linuxdeepin"]},"summary":"Attackers can achieve remote code execution on Deepin Linux systems by tricking users into opening crafted archives with the default compressor.","url":"https://insights.sbomify.com/CVE-2023-50255/"}