# CVE-2023-50255: Zip Path Traversal in Deepin-Compressor

> Attackers can achieve remote code execution on Deepin Linux systems by tricking users into opening crafted archives with the default compressor.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-rw5r-8p9h-3gp2, OESA-2026-3506, OESA-2026-3507, OESA-2026-3508, OESA-2026-3509, openSUSE-SU-2023:0423-1, openSUSE-SU-2023:0424-1, openSUSE-SU-2024:13541-1

## What is CVE-2023-50255?

CVE-2023-50255 is a critical path traversal vulnerability in linuxdeepin developer-center, published on 27 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability.

Weakness: CWE-23 (Relative Path Traversal), CWE-26 (Path Traversal: '/dir/../filename'), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-50255?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deepin-compressor` | SUSE:Package Hub 15 SP4 | All versions | 5.12.2-bp154.2.3.1 |
| `deepin-compressor` | SUSE:Package Hub 15 SP5 | All versions | 5.12.13-bp155.2.3.1 |
| `deepin-compressor` | openSUSE:Leap 15.4 | All versions | 5.12.2-bp154.2.3.1 |
| `deepin-compressor` | openSUSE:Leap 15.5 | All versions | 5.12.13-bp155.2.3.1 |
| `deepin-compressor` | openSUSE:Tumbleweed | All versions | 5.12.13-2.1 |

Products: Deepin Deepin-Compressor.

## How do I fix CVE-2023-50255?

Upgrade to a fixed version.

## Is CVE-2023-50255 being exploited?

There is no known exploitation of CVE-2023-50255 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50255 and fix it if it is affected.

What it is: CVE-2023-50255 is a critical path traversal vulnerability in linuxdeepin developer-center, published on 27 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-50255 in the wild and no public exploit code.

Affected product: linuxdeepin developer-center. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50255/ (Markdown: https://insights.sbomify.com/CVE-2023-50255/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50255
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50255
- OSV: https://osv.dev/vulnerability/CVE-2023-50255

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50255/
Summaries are generated and may contain mistakes; the official description above is the record.
