# CVE-2023-50262: Dompdf possible DoS caused by infinite recursion when parsing SVG images

> An attacker can cause a denial of service in Dompdf by sending malicious SVG images that trigger infinite recursion, exhausting system resources.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** DEBIAN-CVE-2023-50262, GHSA-3qx2-6f78-w2j2

## What is CVE-2023-50262?

CVE-2023-50262 is a medium-severity denial of service vulnerability in dompdf, published on 13 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dompdf is an HTML to PDF converter for PHP. When parsing SVG images Dompdf performs an initial validation to ensure that paths within the SVG are allowed. One of the validations is that the SVG document does not reference itself. However, prior to version 2.0.4, a recursive chained using two or more SVG documents is not correctly validated. Depending on the system configuration and attack pattern this could exhaust the memory available to the executing process and/or to the server itself.

php-svg-lib, when run in isolation, does not support SVG references for `image` elements. However, when used in combination with Dompdf, php-svg-lib will process SVG images referenced by an `image` element. Dompdf currently includes validation to prevent self-referential `image` references, but a chained reference is not checked. A malicious actor may thus trigger infinite recursion by chaining references between two or more SVG images.

When Dompdf parses a malicious payload, it will crash due after exceeding the allowed execution time or memory usage. An attacker sending multiple request to a system can potentially cause resource exhaustion to the point that the system is unable to handle incoming request.

Version 2.0.4 contains a fix for this issue.

Weakness: CWE-674 (Uncontrolled Recursion), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-50262?

2 open source packages ship an affected version, including dompdf/dompdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dompdf/dompdf` | Packagist | All versions | 2.0.4 |
| `dompdf/dompdf` | Packagist | All versions | 2.0.4 |

Products: Dompdf Project Dompdf.

## How do I fix CVE-2023-50262?

Upgrade dompdf/dompdf to 2.0.4 or later.

## Is CVE-2023-50262 being exploited?

There is no known exploitation of CVE-2023-50262 in the wild and no public exploit code.

## Other vulnerabilities in dompdf

- [CVE-2023-24813](https://insights.sbomify.com/CVE-2023-24813/): URI validation failure on SVG parsing. Bypass of CVE-2023-23924 (critical 10.0)
- [CVE-2023-23924](https://insights.sbomify.com/CVE-2023-23924/): URI validation failure on SVG parsing in Dompdf (critical 10.0)
- [CVE-2021-3838](https://insights.sbomify.com/CVE-2021-3838/): PHAR Deserialization in dompdf/dompdf (critical 9.8)
- [CVE-2021-3902](https://insights.sbomify.com/CVE-2021-3902/): Improper Restriction of XML External Entity Reference in dompdf/dompdf (critical 9.8)
- [CVE-2022-28368](https://insights.sbomify.com/CVE-2022-28368/): Remote code injection in dompdf/dompdf (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50262 and fix it if it is affected.

What it is: CVE-2023-50262 is a medium-severity denial of service vulnerability in dompdf, published on 13 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-50262 in the wild and no public exploit code.

Affected packages and fixed versions:
- dompdf/dompdf (Packagist): affected all versions; fixed in 2.0.4
- dompdf/dompdf (Packagist): affected all versions; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50262/ (Markdown: https://insights.sbomify.com/CVE-2023-50262/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50262
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50262
- OSV: https://osv.dev/vulnerability/CVE-2023-50262

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50262/
Summaries are generated and may contain mistakes; the official description above is the record.
