# CVE-2023-50269: SQUID-2023:10 Denial of Service in HTTP Request parsing

> Remote attackers can cause a denial of service in Squid proxy by sending large X-Forwarded-For headers when follow_x_forwarded_for is enabled.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Dec 2023
- **Updated:** 21 May 2025
- **Also known as:** ALPINE-CVE-2023-50269, AZL-32251, CLSA-2024-1706026202, CLSA-2024-1706026402, CLSA-2024-1706026564, CLSA-2024-1706026686, CLSA-2024-1706026919, CLSA-2024-1706027577, CLSA-2024-1706027727, CLSA-2024-1706697415, DEBIAN-CVE-2023-50269, GHSA-wgq4-4cfg-c4x3, OESA-2023-1947, RHSA-2024:1085, ROOT-OS-ALPINE-318-CVE-2023-50269, UBUNTU-CVE-2023-50269

## What is CVE-2023-50269?

CVE-2023-50269 is a high-severity denial of service vulnerability in Squid-Cache Squid, published on 14 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Squid is a caching proxy for the Web. Due to an Uncontrolled Recursion bug in versions 2.6 through 2.7.STABLE9, versions 3.1 through 5.9, and versions 6.0.1 through 6.5, Squid may be vulnerable to a Denial of Service attack against HTTP Request parsing. This problem allows a remote client to perform Denial of Service attack by sending a large X-Forwarded-For header when the follow_x_forwarded_for feature is configured. This bug is fixed by Squid version 6.6. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2023-50269?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `squid` | Red Hat:rhel_eus:9.2::appstream | All versions | 7:5.5-5.el9_2.4 |
| `squid-debuginfo` | Red Hat:rhel_eus:9.2::appstream | All versions | 7:5.5-5.el9_2.4 |
| `squid-debugsource` | Red Hat:rhel_eus:9.2::appstream | All versions | 7:5.5-5.el9_2.4 |

Products: Squid-Cache Squid.

## How do I fix CVE-2023-50269?

Upgrade to a fixed version.

## Is CVE-2023-50269 being exploited?

There is no known exploitation of CVE-2023-50269 in the wild and no public exploit code.

## Other vulnerabilities in Squid-Cache Squid

- [CVE-2025-62168](https://insights.sbomify.com/CVE-2025-62168/): Squid vulnerable to information disclosure via authentication credential leakage in error handling (critical 10.0)
- [CVE-2025-54574](https://insights.sbomify.com/CVE-2025-54574/): Squid's URN Handling can lead to Buffer Overflow (critical 9.3)
- [CVE-2026-33526](https://insights.sbomify.com/CVE-2026-33526/): Squid vulnerable to Denial of Service in ICP Request handling (critical 9.2)
- [CVE-2026-32748](https://insights.sbomify.com/CVE-2026-32748/): Squid has Denial of Service in ICP Response handling (high 8.7)
- [CVE-2023-49285](https://insights.sbomify.com/CVE-2023-49285/): Denial of Service in HTTP Message Processing in Squid (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50269 and fix it if it is affected.

What it is: CVE-2023-50269 is a high-severity denial of service vulnerability in Squid-Cache Squid, published on 14 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-50269 in the wild and no public exploit code.

Affected product: Squid-Cache Squid. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50269/ (Markdown: https://insights.sbomify.com/CVE-2023-50269/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50269
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50269
- OSV: https://osv.dev/vulnerability/CVE-2023-50269

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50269/
Summaries are generated and may contain mistakes; the official description above is the record.
