CVE-2023-50270 Apache DolphinScheduler: Session do not expire after password change
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2023-50270?
CVE-2023-50270 is a medium-severity vulnerability in Apache DolphinScheduler, published on 20 Feb 2024.
Official description
Session Fixation Apache DolphinScheduler before version 3.2.0, which session is still valid after the password change.
Users are recommended to upgrade to version 3.2.1, which fixes this issue.
Which versions are affected by CVE-2023-50270?
2 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.dolphinscheduler:dolphinscheduler Maven | From 1.3.8 | 3.2.1 |
org.apache.dolphinscheduler:dolphinscheduler Maven | From 1.3.8 | 3.2.1 |
Products include Apache Dolphinscheduler.
How do I fix CVE-2023-50270?
Upgrade org.apache.dolphinscheduler:dolphinscheduler to 3.2.1 or later.
Is CVE-2023-50270 being exploited?
There is no known exploitation of CVE-2023-50270 in the wild and no public exploit code.
Other vulnerabilities in Apache DolphinScheduler
- CVE-2024-43166 Apache DolphinScheduler Incorrect Default Permissions Vulnerability
- CVE-2024-43202 Apache DolphinScheduler: Remote Code Execution Vulnerability
- CVE-2023-49109 Remote Code Execution in Apache Dolphinscheduler
- CVE-2022-45875 Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin
- CVE-2022-45462 Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability
Sources
Also known as GHSA-vjqc-g788-f378.