# CVE-2023-50270: Apache DolphinScheduler: Session do not expire after password change


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Feb 2024
- **Updated:** 29 Aug 2024
- **Also known as:** GHSA-vjqc-g788-f378

## What is CVE-2023-50270?

CVE-2023-50270 is a medium-severity vulnerability in Apache DolphinScheduler, published on 20 Feb 2024. 

### Official description

Session Fixation Apache DolphinScheduler before version 3.2.0, which session is still valid after the password change.

Users are recommended to upgrade to version 3.2.1, which fixes this issue.

Weakness: CWE-384 (Session Fixation), CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2023-50270?

2 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | From 1.3.8 | 3.2.1 |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | From 1.3.8 | 3.2.1 |

Products: Apache Dolphinscheduler.

## How do I fix CVE-2023-50270?

Upgrade org.apache.dolphinscheduler:dolphinscheduler to 3.2.1 or later.

## Is CVE-2023-50270 being exploited?

There is no known exploitation of CVE-2023-50270 in the wild and no public exploit code.

## Other vulnerabilities in Apache DolphinScheduler

- [CVE-2024-43166](https://insights.sbomify.com/CVE-2024-43166/): Apache DolphinScheduler Incorrect Default Permissions Vulnerability (critical 9.8)
- [CVE-2024-43202](https://insights.sbomify.com/CVE-2024-43202/): Apache DolphinScheduler: Remote Code Execution Vulnerability (critical 9.8)
- [CVE-2023-49109](https://insights.sbomify.com/CVE-2023-49109/): Remote Code Execution in Apache Dolphinscheduler (critical 9.8)
- [CVE-2022-45875](https://insights.sbomify.com/CVE-2022-45875/): Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin (critical 9.8)
- [CVE-2022-45462](https://insights.sbomify.com/CVE-2022-45462/): Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50270 and fix it if it is affected.

What it is: CVE-2023-50270 is a medium-severity vulnerability in Apache DolphinScheduler, published on 20 Feb 2024. 
Exploitation: There is no known exploitation of CVE-2023-50270 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected from 1.3.8; fixed in 3.2.1
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected from 1.3.8; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50270/ (Markdown: https://insights.sbomify.com/CVE-2023-50270/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50270
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50270
- OSV: https://osv.dev/vulnerability/CVE-2023-50270

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50270/
Summaries are generated and may contain mistakes; the official description above is the record.
