# CVE-2023-50290: Apache Solr: Host environment variables are published via the Metrics API

> Attackers with metrics-read permission can view sensitive host environment variables via the Solr Metrics API, exposing secrets.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2024
- **Updated:** 9 May 2025
- **Also known as:** BIT-solr-2023-50290, GHSA-gg7w-pw2r-x2cq, UBUNTU-CVE-2023-50290

## What is CVE-2023-50290?

CVE-2023-50290 is a medium-severity vulnerability in Apache Solr, published on 15 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Solr.
The Solr Metrics API publishes all unprotected environment variables available to each Apache Solr instance. Users are able to specify which environment variables to hide, however, the default list is designed to work for known secret Java system properties. Environment variables cannot be strictly defined in Solr, like Java system properties can be, and may be set for the entire host, unlike Java system properties which are set per-Java-proccess.

The Solr Metrics API is protected by the "metrics-read" permission.
Therefore, Solr Clouds with Authorization setup will only be vulnerable via users with the "metrics-read" permission.
This issue affects Apache Solr: from 9.0.0 before 9.3.0.

Users are recommended to upgrade to version 9.3.0 or later, in which environment variables are not published via the Metrics API.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-50290?

3 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | From 9.0.0 | 9.3.0 |
| `org.apache.solr:solr-core` | Maven | From 9.0.0 | 9.3.0 |
| `solr` | Bitnami | From 9.0.0 | 9.3.0 |

Products: Apache Solr.

## How do I fix CVE-2023-50290?

Upgrade org.apache.solr:solr-core to 9.3.0 or later.

## Is CVE-2023-50290 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50290 exists.

Public exploit code:

- Bug bounty and vulnerability research reports by Desai Vinayak — includes CVE-2023-50290 (Apache Solr) and Zscaler subdomain takeover findings. (github_poc): https://github.com/desaivinayak449/bug-bounty-reports-desai-vinayak
- Apache Solr - Host Environment Variables Leak via Metrics API (nuclei): http/cves/2023/CVE-2023-50290.yaml

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50290 and fix it if it is affected.

What it is: CVE-2023-50290 is a medium-severity vulnerability in Apache Solr, published on 15 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50290 exists.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected from 9.0.0; fixed in 9.3.0
- org.apache.solr:solr-core (Maven): affected from 9.0.0; fixed in 9.3.0
- solr (Bitnami): affected from 9.0.0; fixed in 9.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50290/ (Markdown: https://insights.sbomify.com/CVE-2023-50290/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50290
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50290
- OSV: https://osv.dev/vulnerability/CVE-2023-50290

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50290/
Summaries are generated and may contain mistakes; the official description above is the record.
