# CVE-2023-50291: Apache Solr: System Property redaction logic inconsistency can lead to leaked passwords

> Authenticated users with config-read permissions can view sensitive system properties, including credentials, via the Solr Admin UI due to insufficient redaction logic.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2024
- **Updated:** 15 May 2025
- **Also known as:** BIT-solr-2023-50291, DEBIAN-CVE-2023-50291, GHSA-3hwc-rqwp-v36q, UBUNTU-CVE-2023-50291

## What is CVE-2023-50291?

CVE-2023-50291 is a high-severity vulnerability in Apache Solr, published on 9 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Insufficiently Protected Credentials vulnerability in Apache Solr.

This issue affects Apache Solr: from 6.0.0 through 8.11.2, from 9.0.0 before 9.3.0.
One of the two endpoints that publishes the Solr process' Java system properties, /admin/info/properties, was only setup to hide system properties that had "password" contained in the name.
There are a number of sensitive system properties, such as "basicauth" and "aws.secretKey" do not contain "password", thus their values were published via the "/admin/info/properties" endpoint.
This endpoint populates the list of System Properties on the home screen of the Solr Admin page, making the exposed credentials visible in the UI.

This /admin/info/properties endpoint is protected under the "config-read" permission.
Therefore, Solr Clouds with Authorization enabled will only be vulnerable through logged-in users that have the "config-read" permission.
Users are recommended to upgrade to version 9.3.0 or 8.11.3, which fixes the issue.
A single option now controls hiding Java system property for all endpoints, "-Dsolr.hiddenSysProps".
By default all known sensitive properties are hidden (including "-Dbasicauth"), as well as any property with a name containing "secret" or "password".

Users who cannot upgrade can also use the following Java system property to fix the issue:
  '-Dsolr.redaction.system.pattern=.*(password|secret|basicauth).*'

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2023-50291?

5 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | From 6.0.0 | 8.11.3 |
| `org.apache.solr:solr-core` | Maven | From 6.0.0 | 8.11.3 |
| `org.apache.solr:solr-core` | Maven | From 9.0.0 | 9.3.0 |
| `org.apache.solr:solr-core` | Maven | From 9.0.0 | 9.3.0 |
| `solr` | Bitnami | From 6.0.0 | 8.11.3, 9.3.0 |

Products: Apache Solr.

## How do I fix CVE-2023-50291?

Upgrade org.apache.solr:solr-core to a fixed version for your release line: 8.11.3 or 9.3.0.

## Is CVE-2023-50291 being exploited?

There is no known exploitation of CVE-2023-50291 in the wild and no public exploit code.

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50291 and fix it if it is affected.

What it is: CVE-2023-50291 is a high-severity vulnerability in Apache Solr, published on 9 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-50291 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected from 6.0.0; fixed in 8.11.3
- org.apache.solr:solr-core (Maven): affected from 6.0.0; fixed in 8.11.3
- org.apache.solr:solr-core (Maven): affected from 9.0.0; fixed in 9.3.0
- org.apache.solr:solr-core (Maven): affected from 9.0.0; fixed in 9.3.0
- solr (Bitnami): affected from 6.0.0; fixed in 8.11.3, 9.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50291/ (Markdown: https://insights.sbomify.com/CVE-2023-50291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50291
- OSV: https://osv.dev/vulnerability/CVE-2023-50291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50291/
Summaries are generated and may contain mistakes; the official description above is the record.
