CVE-2023-50292 Apache Solr: Solr Schema Designer blindly "trusts" all configsets, possibly leading to RCE by unauthenticated users
Unauthenticated users can achieve remote code execution in Apache Solr by exploiting the Schema Designer's failure to validate configset trust levels.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-50292?
CVE-2023-50292 is a high-severity missing authorization vulnerability in Apache Solr, published on 9 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Incorrect Permission Assignment for Critical Resource, Improper Control of Dynamically-Managed Code Resources vulnerability in Apache Solr.
This issue affects Apache Solr: from 8.10.0 through 8.11.2, from 9.0.0 before 9.3.0.
The Schema Designer was introduced to allow users to more easily configure and test new Schemas and configSets. However, when the feature was created, the "trust" (authentication) of these configSets was not considered. External library loading is only available to configSets that are "trusted" (created by authenticated users), thus non-authenticated users are unable to perform Remote Code Execution. Since the Schema Designer loaded configSets without taking their "trust" into account, configSets that were created by unauthenticated users were allowed to load external libraries when used in the Schema Designer.
Users are recommended to upgrade to version 9.3.0, which fixes the issue.
Weakness: CWE-732
Which versions are affected by CVE-2023-50292?
5 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.solr:solr-core Maven | From 8.10.0 | 8.11.3 |
org.apache.solr:solr-core Maven | From 8.10.0 | 8.11.3 |
org.apache.solr:solr-core Maven | From 9.0.0 | 9.3.0 |
org.apache.solr:solr-core Maven | From 9.0.0 | 9.3.0 |
solr Bitnami | From 6.0.0 | 8.11.3, 9.4.1 |
Products include Apache Solr.
How do I fix CVE-2023-50292?
Upgrade org.apache.solr:solr-core to a fixed version for your release line: 8.11.3 or 9.3.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-50292 being exploited?
There is no known exploitation of CVE-2023-50292 in the wild and no public exploit code.
Other vulnerabilities in Apache Solr
- CVE-2019-17558 Apache Solr VelocityResponseWriter Plug-In Remote Code Execution
- CVE-2019-0193 Apache Solr DataImportHandler Code Injection
- CVE-2024-45216 Apache Solr: Authentication bypass possible using a fake URL Path ending
- CVE-2021-44548 Apache Solr information disclosure vulnerability through DataImportHandler
- CVE-2021-27905 SSRF vulnerability with the Replication handler
Sources
Also known as BIT-solr-2023-50292, DEBIAN-CVE-2023-50292, GHSA-4wxw-42wx-2wfx.