# CVE-2023-50292: Apache Solr: Solr Schema Designer blindly "trusts" all configsets, possibly leading to RCE by unauthenticated users

> Unauthenticated users can achieve remote code execution in Apache Solr by exploiting the Schema Designer's failure to validate configset trust levels.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2024
- **Updated:** 15 May 2025
- **Also known as:** BIT-solr-2023-50292, DEBIAN-CVE-2023-50292, GHSA-4wxw-42wx-2wfx

## What is CVE-2023-50292?

CVE-2023-50292 is a high-severity missing authorization vulnerability in Apache Solr, published on 9 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Incorrect Permission Assignment for Critical Resource, Improper Control of Dynamically-Managed Code Resources vulnerability in Apache Solr.

This issue affects Apache Solr: from 8.10.0 through 8.11.2, from 9.0.0 before 9.3.0.

The Schema Designer was introduced to allow users to more easily configure and test new Schemas and configSets.
However, when the feature was created, the "trust" (authentication) of these configSets was not considered.
External library loading is only available to configSets that are "trusted" (created by authenticated users), thus non-authenticated users are unable to perform Remote Code Execution.
Since the Schema Designer loaded configSets without taking their "trust" into account, configSets that were created by unauthenticated users were allowed to load external libraries when used in the Schema Designer.

Users are recommended to upgrade to version 9.3.0, which fixes the issue.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2023-50292?

5 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | From 8.10.0 | 8.11.3 |
| `org.apache.solr:solr-core` | Maven | From 8.10.0 | 8.11.3 |
| `org.apache.solr:solr-core` | Maven | From 9.0.0 | 9.3.0 |
| `org.apache.solr:solr-core` | Maven | From 9.0.0 | 9.3.0 |
| `solr` | Bitnami | From 6.0.0 | 8.11.3, 9.4.1 |

Products: Apache Solr.

## How do I fix CVE-2023-50292?

Upgrade org.apache.solr:solr-core to a fixed version for your release line: 8.11.3 or 9.3.0.

## Is CVE-2023-50292 being exploited?

There is no known exploitation of CVE-2023-50292 in the wild and no public exploit code.

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50292 and fix it if it is affected.

What it is: CVE-2023-50292 is a high-severity missing authorization vulnerability in Apache Solr, published on 9 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-50292 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected from 8.10.0; fixed in 8.11.3
- org.apache.solr:solr-core (Maven): affected from 8.10.0; fixed in 8.11.3
- org.apache.solr:solr-core (Maven): affected from 9.0.0; fixed in 9.3.0
- org.apache.solr:solr-core (Maven): affected from 9.0.0; fixed in 9.3.0
- solr (Bitnami): affected from 6.0.0; fixed in 8.11.3, 9.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50292/ (Markdown: https://insights.sbomify.com/CVE-2023-50292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50292
- OSV: https://osv.dev/vulnerability/CVE-2023-50292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50292/
Summaries are generated and may contain mistakes; the official description above is the record.
