CVE-2023-50298 Apache Solr: Solr can expose ZooKeeper credentials via Streaming Expressions
Attackers can steal ZooKeeper credentials by tricking Solr into connecting to a malicious server via Streaming Expressions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-50298?
CVE-2023-50298 is a high-severity vulnerability in Apache Solr, published on 9 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Solr.This issue affects Apache Solr: from 6.0.0 through 8.11.2, from 9.0.0 before 9.4.1.
Solr Streaming Expressions allows users to extract data from other Solr Clouds, using a "zkHost" parameter. When original SolrCloud is setup to use ZooKeeper credentials and ACLs, they will be sent to whatever "zkHost" the user provides. An attacker could setup a server to mock ZooKeeper, that accepts ZooKeeper requests with credentials and ACLs and extracts the sensitive information, then send a streaming expression using the mock server's address in "zkHost". Streaming Expressions are exposed via the "/streaming" handler, with "read" permissions.
Users are recommended to upgrade to version 8.11.3 or 9.4.1, which fix the issue. From these versions on, only zkHost values that have the same server address (regardless of chroot), will use the given ZooKeeper credentials and ACLs when connecting.
Which versions are affected by CVE-2023-50298?
9 open source packages ship an affected version, including org.apache.solr:solr-solrj, solr and org.apache.solr:solr-solrj-streaming. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.solr:solr-solrj Maven | From 6.0.0 | 8.11.3 |
org.apache.solr:solr-solrj Maven | From 6.0.0 | 8.11.3 |
org.apache.solr:solr-solrj Maven | From 9.0.0 | 9.4.1 |
org.apache.solr:solr-solrj Maven | From 9.0.0 | 9.4.1 |
solr Bitnami | From 6.0.0 | 8.11.3, 9.4.1 |
org.apache.solr:solr-solrj-streaming Maven | From 6.0.0 | 8.11.3 |
3 more packages
org.apache.solr:solr-solrj-streaming Maven | From 6.0.0 | 8.11.3 |
org.apache.solr:solr-solrj-streaming Maven | From 9.0.0 | 9.4.1 |
org.apache.solr:solr-solrj-streaming Maven | From 9.0.0 | 9.4.1 |
Products include Apache Solr.
How do I fix CVE-2023-50298?
Upgrade org.apache.solr:solr-solrj to a fixed version for your release line: 8.11.3 or 9.4.1.
Is CVE-2023-50298 being exploited?
There is no known exploitation of CVE-2023-50298 in the wild and no public exploit code.
Other vulnerabilities in Apache Solr
- CVE-2019-17558 Apache Solr VelocityResponseWriter Plug-In Remote Code Execution
- CVE-2019-0193 Apache Solr DataImportHandler Code Injection
- CVE-2024-45216 Apache Solr: Authentication bypass possible using a fake URL Path ending
- CVE-2021-44548 Apache Solr information disclosure vulnerability through DataImportHandler
- CVE-2021-27905 SSRF vulnerability with the Replication handler
Sources
Also known as BIT-solr-2023-50298, DEBIAN-CVE-2023-50298, ECHO-d571-f177-2fae, GHSA-xrj7-x7gp-wwqr.