{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.ambari:ambari. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-50378 in the wild and no public exploit code.","fix":"Upgrade org.apache.ambari:ambari to 2.7.8 or later.","what":"CVE-2023-50378 is a medium-severity cross-site scripting vulnerability in Apache Ambari, published on 1 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-50378 and fix it if it is affected.\n\nWhat it is: CVE-2023-50378 is a medium-severity cross-site scripting vulnerability in Apache Ambari, published on 1 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-50378 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.ambari:ambari (Maven): affected all versions; fixed in 2.7.8\n- org.apache.ambari:ambari (Maven): affected all versions; fixed in 2.7.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-50378/ (Markdown: https://insights.sbomify.com/CVE-2023-50378/index.md)","id":"CVE-2023-50378","markdown":"https://insights.sbomify.com/CVE-2023-50378/index.md","name":"CVE-2023-50378","record":{"aliases":["GHSA-9q6v-rxmw-g3gh"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Ambari","requires_auth":"none","summary":"Stored XSS in Apache Ambari allows attackers to perform unauthorized actions, including session hijacking and data access.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"ambari","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Lack of proper input validation and constraint enforcement in Apache Ambari prior to 2.7.8  \n\n Impact : As it will be stored XSS, Could be exploited to perform unauthorized actions, varying from data access to session hijacking and delivering malicious payloads. \n\nUsers are recommended to upgrade to version  2.7.8 which fixes this issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Ambari: Various XSS problems","id":"CVE-2023-50378","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Apache Ambari: authenticated users could perform command injection to perform RCE","id":"CVE-2023-50379"},"packages":[{"ecosystem":"Maven","fixed":["2.7.8"],"introduced":["0"],"last_affected":[],"package":"org.apache.ambari:ambari","purl":null,"source":"GHSA-9q6v-rxmw-g3gh"},{"ecosystem":"Maven","fixed":["2.7.8"],"introduced":["0"],"last_affected":[],"package":"org.apache.ambari:ambari","purl":"pkg:maven/org.apache.ambari/ambari","source":"GHSA-9q6v-rxmw-g3gh"}],"prev":{"headline":"WordPress Simple Counter Plugin \u003c= 1.0.2 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-50377"},"products":["Apache Ambari"],"published":"2024-03-01","related":[{"cvss_score":9.8,"headline":"Misconfiguration in Apache Ambari","id":"CVE-2017-5642","kev_date_added":null,"published":"2017-04-03"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2014-3582","kev_date_added":null,"published":"2017-03-29"},{"cvss_score":9.8,"headline":"Apache Ambari Improper Access Control","id":"CVE-2016-6807","kev_date_added":null,"published":"2017-03-28"},{"cvss_score":8.8,"headline":"Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts","id":"CVE-2024-51941","kev_date_added":null,"published":"2025-01-21"},{"cvss_score":8.8,"headline":"Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition","id":"CVE-2025-23196","kev_date_added":null,"published":"2025-01-21"},{"cvss_score":8.8,"headline":"Apache Ambari: authenticated users could perform command injection to perform RCE","id":"CVE-2023-50379","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":8.1,"headline":"Information disclosure in Apache Ambari","id":"CVE-2018-8042","kev_date_added":null,"published":"2018-07-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-07","vendors":["Apache Software Foundation"]},"summary":"Stored XSS in Apache Ambari allows attackers to perform unauthorized actions, including session hijacking and data access.","url":"https://insights.sbomify.com/CVE-2023-50378/"}