# CVE-2023-50378: Apache Ambari: Various XSS problems

> Stored XSS in Apache Ambari allows attackers to perform unauthorized actions, including session hijacking and data access.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Mar 2024
- **Updated:** 7 Nov 2024
- **Also known as:** GHSA-9q6v-rxmw-g3gh

## What is CVE-2023-50378?

CVE-2023-50378 is a medium-severity cross-site scripting vulnerability in Apache Ambari, published on 1 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Lack of proper input validation and constraint enforcement in Apache Ambari prior to 2.7.8  

 Impact : As it will be stored XSS, Could be exploited to perform unauthorized actions, varying from data access to session hijacking and delivering malicious payloads. 

Users are recommended to upgrade to version  2.7.8 which fixes this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-50378?

2 open source packages ship an affected version, including org.apache.ambari:ambari. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ambari:ambari` | Maven | All versions | 2.7.8 |
| `org.apache.ambari:ambari` | Maven | All versions | 2.7.8 |

Products: Apache Ambari.

## How do I fix CVE-2023-50378?

Upgrade org.apache.ambari:ambari to 2.7.8 or later.

## Is CVE-2023-50378 being exploited?

There is no known exploitation of CVE-2023-50378 in the wild and no public exploit code.

## Other vulnerabilities in Apache Ambari

- [CVE-2017-5642](https://insights.sbomify.com/CVE-2017-5642/): Misconfiguration in Apache Ambari (critical 9.8)
- [CVE-2014-3582](https://insights.sbomify.com/CVE-2014-3582/): Command injection in n/a (critical 9.8)
- [CVE-2016-6807](https://insights.sbomify.com/CVE-2016-6807/): Apache Ambari Improper Access Control (critical 9.8)
- [CVE-2024-51941](https://insights.sbomify.com/CVE-2024-51941/): Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts (high 8.8)
- [CVE-2025-23196](https://insights.sbomify.com/CVE-2025-23196/): Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50378 and fix it if it is affected.

What it is: CVE-2023-50378 is a medium-severity cross-site scripting vulnerability in Apache Ambari, published on 1 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-50378 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ambari:ambari (Maven): affected all versions; fixed in 2.7.8
- org.apache.ambari:ambari (Maven): affected all versions; fixed in 2.7.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50378/ (Markdown: https://insights.sbomify.com/CVE-2023-50378/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50378
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50378
- OSV: https://osv.dev/vulnerability/CVE-2023-50378

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50378/
Summaries are generated and may contain mistakes; the official description above is the record.
