CVE-2023-50379 Apache Ambari: authenticated users could perform command injection to perform RCE

High 8.8 Published Updated

Authenticated cluster operators can inject malicious commands to execute arbitrary code with root privileges on the cluster host.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-50379?

CVE-2023-50379 is a high-severity command injection vulnerability in Apache Ambari, published on 27 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Malicious code injection in Apache Ambari in prior to 2.7.8. Users are recommended to upgrade to version 2.7.8, which fixes this issue.

Impact: A Cluster Operator can manipulate the request by adding a malicious code injection and gain a root over the cluster main host.

Weakness: CWE-94

Which versions are affected by CVE-2023-50379?

2 open source packages ship an affected version, including org.apache.ambari.contrib.views:ambari-contrib-views. It affects 1 product.

PackageAffectedFixed in
org.apache.ambari.contrib.views:ambari-contrib-views MavenFrom 2.7.02.7.8
org.apache.ambari.contrib.views:ambari-contrib-views MavenFrom 2.7.02.7.8

Products include Apache Ambari.

How do I fix CVE-2023-50379?

Upgrade org.apache.ambari.contrib.views:ambari-contrib-views to 2.7.8 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2023-50379 being exploited?

There is no known exploitation of CVE-2023-50379 in the wild and no public exploit code.

Sources

Also known as GHSA-rghc-9fhx-h32m.

Is CVE-2023-50379 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free