{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.ambari.contrib.views:ambari-contrib-views. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-50379 in the wild and no public exploit code.","fix":"Upgrade org.apache.ambari.contrib.views:ambari-contrib-views to 2.7.8 or later.","what":"CVE-2023-50379 is a high-severity command injection vulnerability in Apache Ambari, published on 27 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-50379 and fix it if it is affected.\n\nWhat it is: CVE-2023-50379 is a high-severity command injection vulnerability in Apache Ambari, published on 27 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-50379 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.ambari.contrib.views:ambari-contrib-views (Maven): affected from 2.7.0; fixed in 2.7.8\n- org.apache.ambari.contrib.views:ambari-contrib-views (Maven): affected from 2.7.0; fixed in 2.7.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-50379/ (Markdown: https://insights.sbomify.com/CVE-2023-50379/index.md)","id":"CVE-2023-50379","markdown":"https://insights.sbomify.com/CVE-2023-50379/index.md","name":"CVE-2023-50379","record":{"aliases":["GHSA-rghc-9fhx-h32m"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Ambari","requires_auth":"low_privilege","summary":"Authenticated cluster operators can inject malicious commands to execute arbitrary code with root privileges on the cluster host.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"ambari","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Malicious code injection in Apache Ambari in prior to 2.7.8. Users are recommended to upgrade to version 2.7.8, which fixes this issue.\n\nImpact:\nA Cluster Operator can manipulate the request by adding a malicious code injection and gain a root over the cluster main host.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Ambari: authenticated users could perform command injection to perform RCE","id":"CVE-2023-50379","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"command_injection","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Apache Ambari: authenticated users could perform XXE to read arbitrary files on the server","id":"CVE-2023-50380"},"packages":[{"ecosystem":"Maven","fixed":["2.7.8"],"introduced":["2.7.0"],"last_affected":[],"package":"org.apache.ambari.contrib.views:ambari-contrib-views","purl":null,"source":"GHSA-rghc-9fhx-h32m"},{"ecosystem":"Maven","fixed":["2.7.8"],"introduced":["2.7.0"],"last_affected":[],"package":"org.apache.ambari.contrib.views:ambari-contrib-views","purl":"pkg:maven/org.apache.ambari.contrib.views/ambari-contrib-views","source":"GHSA-rghc-9fhx-h32m"}],"prev":{"headline":"Apache Ambari: Various XSS problems","id":"CVE-2023-50378"},"products":["Apache Ambari"],"published":"2024-02-27","related":[{"cvss_score":9.8,"headline":"Misconfiguration in Apache Ambari","id":"CVE-2017-5642","kev_date_added":null,"published":"2017-04-03"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2014-3582","kev_date_added":null,"published":"2017-03-29"},{"cvss_score":9.8,"headline":"Apache Ambari Improper Access Control","id":"CVE-2016-6807","kev_date_added":null,"published":"2017-03-28"},{"cvss_score":8.8,"headline":"Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts","id":"CVE-2024-51941","kev_date_added":null,"published":"2025-01-21"},{"cvss_score":8.8,"headline":"Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition","id":"CVE-2025-23196","kev_date_added":null,"published":"2025-01-21"},{"cvss_score":8.1,"headline":"Information disclosure in Apache Ambari","id":"CVE-2018-8042","kev_date_added":null,"published":"2018-07-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Authenticated cluster operators can inject malicious commands to execute arbitrary code with root privileges on the cluster host.","url":"https://insights.sbomify.com/CVE-2023-50379/"}