# CVE-2023-50379: Apache Ambari: authenticated users could perform command injection to perform RCE

> Authenticated cluster operators can inject malicious commands to execute arbitrary code with root privileges on the cluster host.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-rghc-9fhx-h32m

## What is CVE-2023-50379?

CVE-2023-50379 is a high-severity command injection vulnerability in Apache Ambari, published on 27 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Malicious code injection in Apache Ambari in prior to 2.7.8. Users are recommended to upgrade to version 2.7.8, which fixes this issue.

Impact:
A Cluster Operator can manipulate the request by adding a malicious code injection and gain a root over the cluster main host.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-50379?

2 open source packages ship an affected version, including org.apache.ambari.contrib.views:ambari-contrib-views. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ambari.contrib.views:ambari-contrib-views` | Maven | From 2.7.0 | 2.7.8 |
| `org.apache.ambari.contrib.views:ambari-contrib-views` | Maven | From 2.7.0 | 2.7.8 |

Products: Apache Ambari.

## How do I fix CVE-2023-50379?

Upgrade org.apache.ambari.contrib.views:ambari-contrib-views to 2.7.8 or later.

## Is CVE-2023-50379 being exploited?

There is no known exploitation of CVE-2023-50379 in the wild and no public exploit code.

## Other vulnerabilities in Apache Ambari

- [CVE-2017-5642](https://insights.sbomify.com/CVE-2017-5642/): Misconfiguration in Apache Ambari (critical 9.8)
- [CVE-2014-3582](https://insights.sbomify.com/CVE-2014-3582/): Command injection in n/a (critical 9.8)
- [CVE-2016-6807](https://insights.sbomify.com/CVE-2016-6807/): Apache Ambari Improper Access Control (critical 9.8)
- [CVE-2024-51941](https://insights.sbomify.com/CVE-2024-51941/): Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts (high 8.8)
- [CVE-2025-23196](https://insights.sbomify.com/CVE-2025-23196/): Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50379 and fix it if it is affected.

What it is: CVE-2023-50379 is a high-severity command injection vulnerability in Apache Ambari, published on 27 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-50379 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ambari.contrib.views:ambari-contrib-views (Maven): affected from 2.7.0; fixed in 2.7.8
- org.apache.ambari.contrib.views:ambari-contrib-views (Maven): affected from 2.7.0; fixed in 2.7.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50379/ (Markdown: https://insights.sbomify.com/CVE-2023-50379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50379
- OSV: https://osv.dev/vulnerability/CVE-2023-50379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50379/
Summaries are generated and may contain mistakes; the official description above is the record.
