CVE-2023-50386 Apache Solr: Backup/Restore APIs allow for deployment of executables in malicious ConfigSets
Attackers can upload malicious Java files via ConfigSets API, leading to code execution when backups are restored to classpath directories.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-50386?
CVE-2023-50386 is a high-severity vulnerability in Apache Solr, published on 9 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Control of Dynamically-Managed Code Resources, Unrestricted Upload of File with Dangerous Type, Inclusion of Functionality from Untrusted Control Sphere vulnerability in Apache Solr.This issue affects Apache Solr: from 6.0.0 through 8.11.2, from 9.0.0 before 9.4.1.
In the affected versions, Solr ConfigSets accepted Java jar and class files to be uploaded through the ConfigSets API. When backing up Solr Collections, these configSet files would be saved to disk when using the LocalFileSystemRepository (the default for backups). If the backup was saved to a directory that Solr uses in its ClassPath/ClassLoaders, then the jar and class files would be available to use with any ConfigSet, trusted or untrusted.
When Solr is run in a secure way (Authorization enabled), as is strongly suggested, this vulnerability is limited to extending the Backup permissions with the ability to add libraries. Users are recommended to upgrade to version 8.11.3 or 9.4.1, which fix the issue. In these versions, the following protections have been added:
* Users are no longer able to upload files to a configSet that could be executed via a Java ClassLoader. * The Backup API restricts saving backups to directories that are used in the ClassLoader.
Which versions are affected by CVE-2023-50386?
5 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.solr:solr-core Maven | From 6.0.0 | 8.11.3 |
org.apache.solr:solr-core Maven | From 6.0.0 | 8.11.3 |
org.apache.solr:solr-core Maven | From 9.0.0 | 9.4.1 |
org.apache.solr:solr-core Maven | From 9.0.0 | 9.4.1 |
solr Bitnami | From 6.0.0 | 8.11.3, 9.4.1 |
Products include Apache Solr.
How do I fix CVE-2023-50386?
Upgrade org.apache.solr:solr-core to a fixed version for your release line: 8.11.3 or 9.4.1.
Is CVE-2023-50386 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50386 exists.
Public exploit code: 1 Metasploit module and 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Solr
- CVE-2019-17558 Apache Solr VelocityResponseWriter Plug-In Remote Code Execution
- CVE-2019-0193 Apache Solr DataImportHandler Code Injection
- CVE-2024-45216 Apache Solr: Authentication bypass possible using a fake URL Path ending
- CVE-2021-44548 Apache Solr information disclosure vulnerability through DataImportHandler
- CVE-2021-27905 SSRF vulnerability with the Replication handler
Sources
Also known as BIT-solr-2023-50386, DEBIAN-CVE-2023-50386, GHSA-37vr-vmg4-jwpw.