# CVE-2023-50448: Potential CSV export data leak

> A race condition in ActiveAdmin allows attackers to access private data belonging to other users during CSV export operations.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-356j-hg45-x525

## What is CVE-2023-50448?

CVE-2023-50448 is a medium-severity vulnerability in n/a, published on 28 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In ActiveAdmin (aka Active Admin) before 2.12.0, a concurrency issue allows a malicious actor to access potentially private data (that belongs to another user) by making CSV export requests at certain specific times.

Weakness: CWE-1236 (Improper Neutralization of Formula Elements in a CSV File)

## Which versions are affected by CVE-2023-50448?

2 open source packages ship an affected version, including activeadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activeadmin` | RubyGems | All versions | 2.12.0 |
| `activeadmin` | RubyGems | All versions | 2.12.0 |

Products: Activeadmin Activeadmin.

## How do I fix CVE-2023-50448?

Upgrade activeadmin to 2.12.0 or later.

## Is CVE-2023-50448 being exploited?

There is no known exploitation of CVE-2023-50448 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50448 and fix it if it is affected.

What it is: CVE-2023-50448 is a medium-severity vulnerability in n/a, published on 28 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-50448 in the wild and no public exploit code.

Affected packages and fixed versions:
- activeadmin (RubyGems): affected all versions; fixed in 2.12.0
- activeadmin (RubyGems): affected all versions; fixed in 2.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50448/ (Markdown: https://insights.sbomify.com/CVE-2023-50448/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50448
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50448
- OSV: https://osv.dev/vulnerability/CVE-2023-50448

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50448/
Summaries are generated and may contain mistakes; the official description above is the record.
