# CVE-2023-50550: Layui cross-site scripting (XSS) vulnerability

> An attacker can execute arbitrary scripts in a victim's browser via the data-content parameter in the layui library.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-rcvr-8whx-3m5p

## What is CVE-2023-50550?

CVE-2023-50550 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

layui up to v2.74 was discovered to contain a cross-site scripting (XSS) vulnerability via the data-content parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-50550?

2 open source packages ship an affected version, including layui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `layui` | npm | All versions | 2.7.5 |
| `layui` | npm | All versions | 2.7.5 |

Products: Layui Layui.

## How do I fix CVE-2023-50550?

Upgrade layui to 2.7.5 or later.

## Is CVE-2023-50550 being exploited?

There is no known exploitation of CVE-2023-50550 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-47075](https://insights.sbomify.com/CVE-2024-47075/): DOM Clobbering gadgets found in layui that lead to Cross-site Scripting (medium 6.4)
- [CVE-2023-3691](https://insights.sbomify.com/CVE-2023-3691/): layui HTML Attribute cross site scripting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50550 and fix it if it is affected.

What it is: CVE-2023-50550 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-50550 in the wild and no public exploit code.

Affected packages and fixed versions:
- layui (npm): affected all versions; fixed in 2.7.5
- layui (npm): affected all versions; fixed in 2.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50550/ (Markdown: https://insights.sbomify.com/CVE-2023-50550/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50550
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50550
- OSV: https://osv.dev/vulnerability/CVE-2023-50550

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50550/
Summaries are generated and may contain mistakes; the official description above is the record.
