# CVE-2023-50572: JLine vulnerable to out of memory error

> Attackers can trigger an OutOfMemory error in the GroovyEngine component, causing a denial of service in applications using the jline-groovy library.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Dec 2023
- **Updated:** 7 Oct 2026
- **Also known as:** AZL-66918, AZL-66920, GHSA-2268-98wh-qfhf, UBUNTU-CVE-2023-50572

## What is CVE-2023-50572?

CVE-2023-50572 is a medium-severity denial of service vulnerability in n/a, published on 29 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

An issue in the component GroovyEngine.execute of jline-groovy v3.24.1 allows attackers to cause an OOM (OutofMemory) error.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2023-50572?

2 open source packages ship an affected version, including org.jline:jline-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jline:jline-parent` | Maven | All versions | 3.25.0 |
| `org.jline:jline-parent` | Maven | All versions | 3.25.0 |

Products: Jline Jline.

## How do I fix CVE-2023-50572?

Upgrade org.jline:jline-parent to 3.25.0 or later.

## Is CVE-2023-50572 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50572 exists.

## Other vulnerabilities in n/a

- [CVE-2026-56740](https://insights.sbomify.com/CVE-2026-56740/): JLine: Unauthenticated Remote Memory Exhaustion via Unbounded Telnet NEW-ENVIRON Variables (high 7.5)
- [CVE-2026-56741](https://insights.sbomify.com/CVE-2026-56741/): JLine: Unauthenticated Remote DoS via Unbounded Telnet NAWS Terminal Geometry (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50572 and fix it if it is affected.

What it is: CVE-2023-50572 is a medium-severity denial of service vulnerability in n/a, published on 29 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50572 exists.

Affected packages and fixed versions:
- org.jline:jline-parent (Maven): affected all versions; fixed in 3.25.0
- org.jline:jline-parent (Maven): affected all versions; fixed in 3.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50572/ (Markdown: https://insights.sbomify.com/CVE-2023-50572/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50572
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50572
- OSV: https://osv.dev/vulnerability/CVE-2023-50572

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50572/
Summaries are generated and may contain mistakes; the official description above is the record.
