CVE-2023-5061 Missing Authorization in GitLab

Medium 4.3 Published Updated

Developers can override predefined CI variables via the REST API, potentially altering build configurations and bypassing security controls.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-5061?

CVE-2023-5061 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 15 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 9.3 before 16.4.4, all versions starting from 16.5 before 16.5.4, all versions starting from 16.6 before 16.6.2. In certain situations, it may have been possible for developers to override predefined CI variables via the REST API.

Weakness: CWE-862

Which versions are affected by CVE-2023-5061?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 9.3.016.4.4, 16.5.4, 16.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-5061?

Upgrade gitlab to a fixed version for your release line: 16.4.4, 16.5.4 or 16.6.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-5061 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5061 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-5061, GHSA-v64g-f7qf-63xm, UBUNTU-CVE-2023-5061.

Is CVE-2023-5061 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free