# CVE-2023-50708: yii2-authclient vulnerable to possible timing attack on string comparison in OAuth1, OAuth2 and OpenID Connect implementation

> Attackers can exploit timing side-channels in OAuth and OpenID Connect state/nonce validation to bypass security checks in the Yii2 authentication extension.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-w8vh-p74j-x9xp

## What is CVE-2023-50708?

CVE-2023-50708 is a medium-severity vulnerability in yiisoft yii2-authclient, published on 22 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

yii2-authclient is an extension that adds OpenID, OAuth, OAuth2 and OpenId Connect consumers for the Yii framework 2.0. In yii2-authclient prior to version 2.2.15, the Oauth1/2 `state` and OpenID Connect `nonce` is vulnerable for a `timing attack` since it is compared via regular string comparison (instead of `Yii::$app->getSecurity()->compareString()`). Version 2.2.15 contains a patch for the issue. No known workarounds are available.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2023-50708?

2 open source packages ship an affected version, including yiisoft/yii2-authclient. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yiisoft/yii2-authclient` | Packagist | All versions | 2.2.15 |
| `yiisoft/yii2-authclient` | Packagist | All versions | 2.2.15 |

Products: Yiiframework Yii2-Authclient.

## How do I fix CVE-2023-50708?

Upgrade yiisoft/yii2-authclient to 2.2.15 or later.

## Is CVE-2023-50708 being exploited?

There is no known exploitation of CVE-2023-50708 in the wild and no public exploit code.

## Other vulnerabilities in yiisoft yii2-authclient

- [CVE-2023-50714](https://insights.sbomify.com/CVE-2023-50714/): The Oauth2 PKCE implementation is vulnerable (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50708 and fix it if it is affected.

What it is: CVE-2023-50708 is a medium-severity vulnerability in yiisoft yii2-authclient, published on 22 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-50708 in the wild and no public exploit code.

Affected packages and fixed versions:
- yiisoft/yii2-authclient (Packagist): affected all versions; fixed in 2.2.15
- yiisoft/yii2-authclient (Packagist): affected all versions; fixed in 2.2.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50708/ (Markdown: https://insights.sbomify.com/CVE-2023-50708/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50708
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50708
- OSV: https://osv.dev/vulnerability/CVE-2023-50708

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50708/
Summaries are generated and may contain mistakes; the official description above is the record.
