{"answers":{"affected":"2 open source packages ship an affected version, including @cubejs-backend/api-gateway. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-50709 in the wild and no public exploit code.","fix":"Upgrade @cubejs-backend/api-gateway to 0.34.34 or later.","what":"CVE-2023-50709 is a medium-severity denial of service vulnerability in cube-js cube, published on 13 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-50709 and fix it if it is affected.\n\nWhat it is: CVE-2023-50709 is a medium-severity denial of service vulnerability in cube-js cube, published on 13 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-50709 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @cubejs-backend/api-gateway (npm): affected all versions; fixed in 0.34.34\n- @cubejs-backend/api-gateway (npm): affected all versions; fixed in 0.34.34\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-50709/ (Markdown: https://insights.sbomify.com/CVE-2023-50709/index.md)","id":"CVE-2023-50709","markdown":"https://insights.sbomify.com/CVE-2023-50709/index.md","name":"CVE-2023-50709","record":{"aliases":["GHSA-9759-3276-g2pm"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Cube semantic layer","requires_auth":"low_privilege","summary":"Attackers can cause service disruption by sending crafted requests to the Cube API, requiring users to upgrade to the latest version.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"cube.js","vendor":"cube"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Cube is a semantic layer for building data applications. Prior to version 0.34.34, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. The issue has been patched in `v0.34.34` and it's recommended that all users exposing Cube APIs to the public internet upgrade to the latest version to prevent service disruption.\nThere are currently no workaround for older versions, and the recommendation is to upgrade.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service attack on the cube-api endpoint","id":"CVE-2023-50709","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Hono's named path parameters can be overridden in TrieRouter","id":"CVE-2023-50710"},"packages":[{"ecosystem":"npm","fixed":["0.34.34"],"introduced":["0"],"last_affected":[],"package":"@cubejs-backend/api-gateway","purl":null,"source":"GHSA-9759-3276-g2pm"},{"ecosystem":"npm","fixed":["0.34.34"],"introduced":["0"],"last_affected":[],"package":"@cubejs-backend/api-gateway","purl":"pkg:npm/%40cubejs-backend/api-gateway","source":"GHSA-9759-3276-g2pm"}],"prev":{"headline":"yii2-authclient vulnerable to possible timing attack on string comparison in OAuth1, OAuth2 and OpenID Connect implementation","id":"CVE-2023-50708"},"products":["cube"],"published":"2023-12-13","related":[{"cvss_score":9.6,"headline":"SQl injection in cube-js","id":"CVE-2022-23510","kev_date_added":null,"published":"2022-12-09"},{"cvss_score":7.7,"headline":"Cube privilege escalation via a specially crafted request","id":"CVE-2026-25958","kev_date_added":null,"published":"2026-02-09"},{"cvss_score":6.5,"headline":"Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request","id":"CVE-2026-25957","kev_date_added":null,"published":"2026-02-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-08","vendors":["cube-js"]},"summary":"Attackers can cause service disruption by sending crafted requests to the Cube API, requiring users to upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2023-50709/"}