# CVE-2023-50709: Denial of service attack on the cube-api endpoint

> Attackers can cause service disruption by sending crafted requests to the Cube API, requiring users to upgrade to the latest version.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Dec 2023
- **Updated:** 8 Oct 2024
- **Also known as:** GHSA-9759-3276-g2pm

## What is CVE-2023-50709?

CVE-2023-50709 is a medium-severity denial of service vulnerability in cube-js cube, published on 13 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cube is a semantic layer for building data applications. Prior to version 0.34.34, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. The issue has been patched in `v0.34.34` and it's recommended that all users exposing Cube APIs to the public internet upgrade to the latest version to prevent service disruption.
There are currently no workaround for older versions, and the recommendation is to upgrade.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-50709?

2 open source packages ship an affected version, including @cubejs-backend/api-gateway. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@cubejs-backend/api-gateway` | npm | All versions | 0.34.34 |
| `@cubejs-backend/api-gateway` | npm | All versions | 0.34.34 |

Products: Cube Cube.js.

## How do I fix CVE-2023-50709?

Upgrade @cubejs-backend/api-gateway to 0.34.34 or later.

## Is CVE-2023-50709 being exploited?

There is no known exploitation of CVE-2023-50709 in the wild and no public exploit code.

## Other vulnerabilities in cube-js cube

- [CVE-2022-23510](https://insights.sbomify.com/CVE-2022-23510/): SQl injection in cube-js (critical 9.6)
- [CVE-2026-25958](https://insights.sbomify.com/CVE-2026-25958/): Cube privilege escalation via a specially crafted request (high 7.7)
- [CVE-2026-25957](https://insights.sbomify.com/CVE-2026-25957/): Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50709 and fix it if it is affected.

What it is: CVE-2023-50709 is a medium-severity denial of service vulnerability in cube-js cube, published on 13 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-50709 in the wild and no public exploit code.

Affected packages and fixed versions:
- @cubejs-backend/api-gateway (npm): affected all versions; fixed in 0.34.34
- @cubejs-backend/api-gateway (npm): affected all versions; fixed in 0.34.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50709/ (Markdown: https://insights.sbomify.com/CVE-2023-50709/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50709
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50709
- OSV: https://osv.dev/vulnerability/CVE-2023-50709

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50709/
Summaries are generated and may contain mistakes; the official description above is the record.
