{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-50713 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-50713 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-50713 is a medium-severity vulnerability in specklesystems speckle-server, published on 14 Dec 2023."},"fix_prompt":"Check this codebase for CVE-2023-50713 and fix it if it is affected.\n\nWhat it is: CVE-2023-50713 is a medium-severity vulnerability in specklesystems speckle-server, published on 14 Dec 2023. \nExploitation: There is no known exploitation of CVE-2023-50713 in the wild and no public exploit code.\n\nAffected product: specklesystems speckle-server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-50713/ (Markdown: https://insights.sbomify.com/CVE-2023-50713/index.md)","id":"CVE-2023-50713","markdown":"https://insights.sbomify.com/CVE-2023-50713/index.md","name":"CVE-2023-50713","record":{"aliases":["GHSA-xpf3-5q5x-3qwh"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"speckle_server","vendor":"specklesystems"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-1220","name":"Insufficient Granularity of Access Control"}],"description":"Speckle Server provides server, frontend, 3D viewer, and other JavaScript utilities for the Speckle 3D data platform. A vulnerability in versions prior to 2.17.6 affects users who: authorized an application which requested a 'token write' scope or, using frontend-2, created a Personal Access Token (PAT) with `token write` scope. When creating a new token an agent needs to authorise the request with an existing token (the 'requesting token').  The requesting token is required to have token write scope in order to generate new tokens. However, Speckle server was not verifying that other privileges granted to the new token were not in excess of the privileges of the requesting token. A malicious actor could use a token with only token write scope to subsequently generate further tokens with additional privileges. These privileges would only grant privileges up to the existing privileges of the user. This vulnerability cannot be used to escalate a user's privileges or grant privileges on behalf of other users.\n\nThis has been patched as of version 2.17.6. All operators of Speckle servers should upgrade their server to version 2.17.6 or higher. Any users who authorized an application with 'token write' scope, or created a token in frontend-2 with `token write` scope should review existing tokens and permanently revoke any they do not recognize, revoke existing tokens and create new tokens, and review usage of their account for suspicious activity. No known workarounds for this issue exist.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Speckle Server API Token Privilege Escalation","id":"CVE-2023-50713","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2023"},"n_packages":0,"n_references":3,"next":{"headline":"The Oauth2 PKCE implementation is vulnerable","id":"CVE-2023-50714"},"packages":[],"prev":{"headline":"Improper Neutralization of Alternate XSS Syntax in iris-web","id":"CVE-2023-50712"},"products":["speckle-server"],"published":"2023-12-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["specklesystems"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2023-50713/"}