CVE-2023-50714 The Oauth2 PKCE implementation is vulnerable

Medium 6.8 Published Updated

Attackers can bypass PKCE protections in the Yii2 OAuth2 extension, potentially enabling CSRF or downgrade attacks if PKCE is relied upon for security.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-50714?

CVE-2023-50714 is a medium-severity vulnerability in yiisoft yii2-authclient, published on 22 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

yii2-authclient is an extension that adds OpenID, OAuth, OAuth2 and OpenId Connect consumers for the Yii framework 2.0. In yii2-authclient prior to version 2.2.15, the Oauth2 PKCE implementation is vulnerable in 2 ways. First, the `authCodeVerifier` should be removed after usage (similar to `authState`). Second, there is a risk for a `downgrade attack` if PKCE is being relied on for CSRF protection. Version 2.2.15 contains a patch for the issue. No known workarounds are available.

Weakness: CWE-287, CWE-918, CWE-347

Which versions are affected by CVE-2023-50714?

2 open source packages ship an affected version, including yiisoft/yii2-authclient. It affects 1 product.

PackageAffectedFixed in
yiisoft/yii2-authclient PackagistAll versions2.2.15
yiisoft/yii2-authclient PackagistAll versions2.2.15

Products include Yiiframework Yii2-Authclient.

How do I fix CVE-2023-50714?

Upgrade yiisoft/yii2-authclient to 2.2.15 or later.

Is CVE-2023-50714 being exploited?

There is no known exploitation of CVE-2023-50714 in the wild and no public exploit code.

Sources

Also known as GHSA-rw54-6826-c8j5.

Is CVE-2023-50714 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free