{"answers":{"affected":"2 open source packages ship an affected version, including yiisoft/yii2-authclient. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-50714 in the wild and no public exploit code.","fix":"Upgrade yiisoft/yii2-authclient to 2.2.15 or later.","what":"CVE-2023-50714 is a medium-severity vulnerability in yiisoft yii2-authclient, published on 22 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-50714 and fix it if it is affected.\n\nWhat it is: CVE-2023-50714 is a medium-severity vulnerability in yiisoft yii2-authclient, published on 22 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-50714 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yiisoft/yii2-authclient (Packagist): affected all versions; fixed in 2.2.15\n- yiisoft/yii2-authclient (Packagist): affected all versions; fixed in 2.2.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-50714/ (Markdown: https://insights.sbomify.com/CVE-2023-50714/index.md)","id":"CVE-2023-50714","markdown":"https://insights.sbomify.com/CVE-2023-50714/index.md","name":"CVE-2023-50714","record":{"aliases":["GHSA-rw54-6826-c8j5"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Yii2 OAuth2 extension","requires_auth":"none","summary":"Attackers can bypass PKCE protections in the Yii2 OAuth2 extension, potentially enabling CSRF or downgrade attacks if PKCE is relied upon for security.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yii2-authclient","vendor":"yiiframework"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"},{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"yii2-authclient is an extension that adds OpenID, OAuth, OAuth2 and OpenId Connect consumers for the Yii framework 2.0. In yii2-authclient prior to version 2.2.15, the Oauth2 PKCE implementation is vulnerable in 2 ways. First, the `authCodeVerifier` should be removed after usage (similar to `authState`). Second, there is a risk for a `downgrade attack` if PKCE is being relied on for CSRF protection. Version 2.2.15 contains a patch for the issue. No known workarounds are available.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"The Oauth2 PKCE implementation is vulnerable","id":"CVE-2023-50714","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"security_feature_bypass","year":"2023"},"n_packages":2,"n_references":5,"next":{"headline":"User accounts disclosed to unauthenticated actors on the LAN","id":"CVE-2023-50715"},"packages":[{"ecosystem":"Packagist","fixed":["2.2.15"],"introduced":["0"],"last_affected":[],"package":"yiisoft/yii2-authclient","purl":null,"source":"GHSA-rw54-6826-c8j5"},{"ecosystem":"Packagist","fixed":["2.2.15"],"introduced":["0"],"last_affected":[],"package":"yiisoft/yii2-authclient","purl":"pkg:composer/yiisoft/yii2-authclient","source":"GHSA-rw54-6826-c8j5"}],"prev":{"headline":"Speckle Server API Token Privilege Escalation","id":"CVE-2023-50713"},"products":["yii2-authclient"],"published":"2023-12-22","related":[{"cvss_score":6.1,"headline":"yii2-authclient vulnerable to possible timing attack on string comparison in OAuth1, OAuth2 and OpenID Connect implementation","id":"CVE-2023-50708","kev_date_added":null,"published":"2023-12-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-27","vendors":["yiisoft"]},"summary":"Attackers can bypass PKCE protections in the Yii2 OAuth2 extension, potentially enabling CSRF or downgrade attacks if PKCE is relied upon for security.","url":"https://insights.sbomify.com/CVE-2023-50714/"}