# CVE-2023-50715: User accounts disclosed to unauthenticated actors on the LAN

> Unauthenticated users on the local network can view all active Home Assistant user accounts, exposing sensitive identity information.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-jqpc-rc7g-vf83, PYSEC-2026-1451

## What is CVE-2023-50715?

CVE-2023-50715 is a medium-severity vulnerability in home-assistant core, published on 15 Dec 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Home Assistant is open source home automation software. Prior to version 2023.12.3, the login page discloses all active user accounts to any unauthenticated browsing request originating on the Local Area Network. Version 2023.12.3 contains a patch for this issue.

When starting the Home Assistant 2023.12 release, the login page returns all currently active user accounts to browsing requests from the Local Area Network. Tests showed that this occurs when the request is not authenticated and the request originated locally, meaning on the Home Assistant host local subnet or any other private subnet. The rationale behind this is to make the login more user-friendly and an experience better aligned with other applications that have multiple user-profiles.

However, as a result, all accounts are displayed regardless of them having logged in or not and for any device that navigates to the server. This disclosure is mitigated by the fact that it only occurs for requests originating from a LAN address. But note that this applies to the local subnet where Home Assistant resides and to any private subnet that can reach it.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-50715?

3 open source packages ship an affected version, including homeassistant. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `homeassistant` | PyPI | All versions | 2023.12.3 |
| `homeassistant` | PyPI | All versions | 2023.12.3 |
| `homeassistant` | PyPI | All versions | 2023.12.3 |

Products: Home-Assistant Home-Assistant.

## How do I fix CVE-2023-50715?

Upgrade homeassistant to 2023.12.3 or later.

## Is CVE-2023-50715 being exploited?

There is no known exploitation of CVE-2023-50715 in the wild and no public exploit code.

## Other vulnerabilities in home-assistant core

- [CVE-2023-27482](https://insights.sbomify.com/CVE-2023-27482/): Auth bypass in core (critical 10.0)
- [CVE-2023-41895](https://insights.sbomify.com/CVE-2023-41895/): Cross-site Scripting via auth_callback login in Home Assistant Core (high 8.8)
- [CVE-2023-41897](https://insights.sbomify.com/CVE-2023-41897/): Lack of XFO header allows clickjacking in Home Assistant Core (high 8.8)
- [CVE-2026-54317](https://insights.sbomify.com/CVE-2026-54317/): Home Assistant: Konnected alarm-panel switch state and zone topology disclosed to unauthenticated actors on the LAN (high 7.6)
- [CVE-2020-36517](https://insights.sbomify.com/CVE-2020-36517/): Information disclosure in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50715 and fix it if it is affected.

What it is: CVE-2023-50715 is a medium-severity vulnerability in home-assistant core, published on 15 Dec 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-50715 in the wild and no public exploit code.

Affected packages and fixed versions:
- homeassistant (PyPI): affected all versions; fixed in 2023.12.3
- homeassistant (PyPI): affected all versions; fixed in 2023.12.3
- homeassistant (PyPI): affected all versions; fixed in 2023.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50715/ (Markdown: https://insights.sbomify.com/CVE-2023-50715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50715
- OSV: https://osv.dev/vulnerability/CVE-2023-50715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50715/
Summaries are generated and may contain mistakes; the official description above is the record.
