# CVE-2023-50717: NocoDB Allows Preview of File with Dangerous Content

> Attackers can upload malicious HTML files to trigger stored XSS, allowing script execution and data theft in victim browsers.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-qg73-g3cf-vhhh

## What is CVE-2023-50717?

CVE-2023-50717 is a medium-severity cross-site scripting vulnerability in nocodb, published on 13 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

NocoDB is software for building databases as spreadsheets. Starting in verson 0.202.6 and prior to version 0.202.10, an attacker can upload a html file with malicious content. If user tries to open that file in browser malicious scripts can be executed leading  stored cross-site scripting attack. This allows remote attacker to execute JavaScript code in the context of the user accessing the vector. An attacker could have used this vulnerability to execute requests in the name of a logged-in user or potentially collect information about the attacked user by displaying a malicious form. Version 0.202.10 contains a patch for the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2023-50717?

2 open source packages ship an affected version, including nocodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | From 0.202.6 | 0.202.10 |
| `nocodb` | npm | From 0.202.6 | 0.202.10 |

Products: Nocodb Nocodb.

## How do I fix CVE-2023-50717?

Upgrade nocodb to 0.202.10 or later.

## Is CVE-2023-50717 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50717 exists.

## Other vulnerabilities in nocodb

- [CVE-2022-2339](https://insights.sbomify.com/CVE-2022-2339/): Server-Side Request Forgery (SSRF) in nocodb/nocodb (critical 9.1)
- [CVE-2022-2062](https://insights.sbomify.com/CVE-2022-2062/): Generation of Error Message Containing Sensitive Information in nocodb/nocodb (critical 9.1)
- [CVE-2022-2064](https://insights.sbomify.com/CVE-2022-2064/): Insufficient Session Expiration in nocodb/nocodb (critical 9.1)
- [CVE-2022-2063](https://insights.sbomify.com/CVE-2022-2063/): Improper Privilege Management in nocodb/nocodb (critical 9.0)
- [CVE-2022-2022](https://insights.sbomify.com/CVE-2022-2022/): Cross-site Scripting (XSS) - Stored in nocodb/nocodb (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50717 and fix it if it is affected.

What it is: CVE-2023-50717 is a medium-severity cross-site scripting vulnerability in nocodb, published on 13 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50717 exists.

Affected packages and fixed versions:
- nocodb (npm): affected from 0.202.6; fixed in 0.202.10
- nocodb (npm): affected from 0.202.6; fixed in 0.202.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50717/ (Markdown: https://insights.sbomify.com/CVE-2023-50717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50717
- OSV: https://osv.dev/vulnerability/CVE-2023-50717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50717/
Summaries are generated and may contain mistakes; the official description above is the record.
