# CVE-2023-50718: NocoDB SQL Injection vulnerability

> An authenticated attacker with create access can exploit SQL injection in NocoDB to leak sensitive database information.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2024
- **Updated:** 21 Aug 2024
- **Also known as:** GHSA-8fxg-mr34-jqr8

## What is CVE-2023-50718?

CVE-2023-50718 is a medium-severity SQL injection vulnerability in nocodb, published on 13 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

NocoDB is software for building databases as spreadsheets. Prior to version 0.202.10, an authenticated attacker with create access could conduct a SQL Injection attack on MySQL DB using unescaped `table_name`. This vulnerability may result in leakage of sensitive data in the database. Version 0.202.10 contains a patch for the issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2023-50718?

2 open source packages ship an affected version, including nocodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions | 0.202.10 |
| `nocodb` | npm | All versions | 0.202.10 |

Products: Nocodb Nocodb.

## How do I fix CVE-2023-50718?

Upgrade nocodb to 0.202.10 or later.

## Is CVE-2023-50718 being exploited?

There is no known exploitation of CVE-2023-50718 in the wild and no public exploit code.

## Other vulnerabilities in nocodb

- [CVE-2022-2339](https://insights.sbomify.com/CVE-2022-2339/): Server-Side Request Forgery (SSRF) in nocodb/nocodb (critical 9.1)
- [CVE-2022-2062](https://insights.sbomify.com/CVE-2022-2062/): Generation of Error Message Containing Sensitive Information in nocodb/nocodb (critical 9.1)
- [CVE-2022-2064](https://insights.sbomify.com/CVE-2022-2064/): Insufficient Session Expiration in nocodb/nocodb (critical 9.1)
- [CVE-2022-2063](https://insights.sbomify.com/CVE-2022-2063/): Improper Privilege Management in nocodb/nocodb (critical 9.0)
- [CVE-2022-2022](https://insights.sbomify.com/CVE-2022-2022/): Cross-site Scripting (XSS) - Stored in nocodb/nocodb (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50718 and fix it if it is affected.

What it is: CVE-2023-50718 is a medium-severity SQL injection vulnerability in nocodb, published on 13 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-50718 in the wild and no public exploit code.

Affected packages and fixed versions:
- nocodb (npm): affected all versions; fixed in 0.202.10
- nocodb (npm): affected all versions; fixed in 0.202.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50718/ (Markdown: https://insights.sbomify.com/CVE-2023-50718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50718
- OSV: https://osv.dev/vulnerability/CVE-2023-50718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50718/
Summaries are generated and may contain mistakes; the official description above is the record.
