# CVE-2023-50719: XWiki Platform Solr search discloses password hashes of all users

> Attackers with view rights can access password hashes and sensitive configuration data via the Solr search feature.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2023
- **Updated:** 8 Oct 2024
- **Also known as:** GHSA-p6cp-6r35-32mh

## What is CVE-2023-50719?

CVE-2023-50719 is a high-severity vulnerability in Xwiki Xwiki, published on 15 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Starting in 7.2-milestone-2 and prior to versions 14.10.15, 15.5.2, and 15.7-rc-1, the Solr-based search in XWiki discloses the password hashes of all users to anyone with view right on the respective user profiles. By default, all user profiles are public. This vulnerability also affects any configurations used by extensions that contain passwords like API keys that are viewable for the attacker. Normally, such passwords aren't accessible but this vulnerability would disclose them as plain text.  This has been patched in XWiki 14.10.15, 15.5.2 and 15.7RC1. There are no known workarounds for this vulnerability.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information), CWE-359 (Exposure of Private Personal Information to an Unauthorized Actor), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-50719?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-search-solr-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 15.0-rc-1 | 15.5.2 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 15.0-rc-1 | 15.5.2 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 15.6-rc-1 | 15.7-rc-1 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 15.6-rc-1 | 15.7-rc-1 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 7.2-milestone-2 | 14.10.15 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 7.2-milestone-2 | 14.10.15 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-50719?

Upgrade org.xwiki.platform:xwiki-platform-search-solr-api to a fixed version for your release line: 15.5.2, 15.7-rc-1 or 14.10.15.

## Is CVE-2023-50719 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50719 exists.

Public exploit code:

- XWiki < 4.10.15 - Sensitive Information Disclosure (nuclei): http/cves/2023/CVE-2023-50719.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50719 and fix it if it is affected.

What it is: CVE-2023-50719 is a high-severity vulnerability in Xwiki Xwiki, published on 15 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50719 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 15.0-rc-1; fixed in 15.5.2
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 15.0-rc-1; fixed in 15.5.2
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 15.6-rc-1; fixed in 15.7-rc-1
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 15.6-rc-1; fixed in 15.7-rc-1
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 7.2-milestone-2; fixed in 14.10.15
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 7.2-milestone-2; fixed in 14.10.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50719/ (Markdown: https://insights.sbomify.com/CVE-2023-50719/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50719
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50719
- OSV: https://osv.dev/vulnerability/CVE-2023-50719

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50719/
Summaries are generated and may contain mistakes; the official description above is the record.
